
  
    
  
Reconciliation



Once transactions have been entered into GnuCash, it is important to verify
      that they agree with the records of your financial institution. This
      verification process is known as reconciliation, and it is key to determine
      whether your records are accurate. Most commonly, you will check transactions
      against bank statements, although you can use this process to verify any
      transaction.
GnuCash keeps track of the reconciliation status of each
        transaction. The reconciliation status of a transaction is shown by the
        reconciliation R field in a register:
        y indicates that a transaction has been
        reconciled, n indicates that it has not, and c indicates that it has
        been cleared, but not reconciled. A split marked cleared signifies that you got some kind of confirmation
        that the institution accepted the order (e.g. you have the restaurant's receipt for your credit card purchase).
        You can toggle the reconciliation status
        between n and c by clicking in the R field; you can set
        it to y by using the section called “Reconcile windows”.
At the bottom of the account window, there are (among others) two running
      balances (the cleared and reconciled balance), and the
      total balance. The former balances should correspond to how much money
      the bank thinks you have in your account, while the latter includes outstanding transactions.
For example, when you write a check for something, you should
      enter the transaction into GnuCash. The reconciliation R field of the
      transaction will initially contain n (new). Your new entry will
      contribute to the total balance, but not to the cleared and
      reconciled balance. Later, if you got some confirmation that the check has been cashed,
      you might click on the transaction’s R field to change it to c
      (cleared). When you do this, the cleared balance will
      change to include this amount. When the bank statement arrives, you can
      then compare it to what you’ve recorded in GnuCash by opening the reconciliation
      window. There, you will be able to change the R field to y (reconciled).
Note
You cannot reconcile directly in a register window by clicking in the R field. You must use the
        reconciliation window. Once a transaction has been marked reconciled,
        it can no longer be easily changed without breaking the
        Starting Balance of the next reconciliation.

Warning
It is important to understand that reconciliation is done for a given
        date, and when you reconcile an account based on a statement from a given date,
        you are reconciling all transactions prior to that date. Therefore, if you
        add or modify transactions that predate your last reconciliation, your
        reconciled balances will be thrown off.

Reconcile windows



The reconciliation windows are used to reconcile a GnuCash account
      with a statement that a bank or other institution has sent you.
      Reconciliation is useful not only to double-check your records against
      those of your bank, but also to get a better idea of outstanding
      transactions, e.g. uncashed checks.
To use the reconciliation windows, select an account from the
      account tree and click on Actions → Reconcile. A window like the one below will appear in which you can
      enter the reconcile information.
[image: Reconcile Window]The initial reconcile window.



In the initial reconcile window, some Reconcile Information need to be entered.
	Statement Date
	The date of the statement you will be reconciling against.
Tip
Click on the down arrow in the right of this field to open a calendar


	Starting Balance
	This is a non-editable item which displays the balance from the previous
              reconciliation. It should match the starting balance in your statement.
Warning
Sometimes, the opening balance in GnuCash does not match
              that found on your statement. This can happen the first time you reconcile your account or
              when a previously-reconciled transaction is de-reconciled or deleted.

Note
The first time you reconcile your account, the starting balance
              will be 0.00, thus probably not the  opening balance
              of your account. When you reconcile the account, the opening balance for the
              account will be included in the reconciliation, and the result should balance.

Tip
In the case when a previously-reconciled transaction is accidentally de-reconciled, you
                can simply re-reconcile the transaction along with the transactions on the current statement, and
                the result should balance.
The case of accidentally deleting a previously-reconciled transaction presents
                more of a challenge; if you cannot determine what was
                deleted and restore it to the register, you will have to create a dummy
                transaction to get the reconciliation to finish.

Caution
While the latter case does not matter for your private accounting,
              you should have a really good explanation for your auditors, if you are the
              accountant of a club or a company.


	Ending Balance
	This field should be filled with the ending balance as it appears in the statement.
Note
GnuCash automatically fills this field with the
	    Present balance as shown in the lower part of the
	    account’s register.


	Include Sub-accounts
	Check this option if you want to include in the reconciliation the transactions
            that belongs to the sub-accounts of the currently selected account. Note that all sub-accounts must be in the same commodity as the parent for the option to be enabled.

	Enter Interest Payment
	Clicking this button opens a new window that allow you to enter an interest transaction to the account to be
            reconciled.
Tip
The Interest Payment window might be opened automatically when you start a reconciliation
	      for an account of the type Bank, Credit,
	      Mutual, Asset, Receivable,
	      Payable, and Liability. If you want to disable
	      this behavior for any of the previous accounts, go to the Register tab of the
	      GnuCash Preferences and uncheck the Automatic interest transfer
	      option. Alternatively, to disable this behavior only for the selected account, press the
	      No Auto Interest Payments for this Account button in the
	      Interest Payment window.




Then, click on the Ok button, and you will see
      the transactions listing reconcile window:
[image: Reconcile Window]The transactions listing in the reconcile
          window.



The two panes called Funds In and
      Funds Out, lists all the unreconciled transactions that belongs to the account
      that is going to be reconciled.
      The R columns show whether the transactions have been reconciled.
Now, examine each item on the bank statement, and look for the
      matching item in the Reconcile window.
If you cannot find a transaction, then perhaps you forgot to enter it, or did not know that the transaction
      had happened. You can use the New button on the Toolbar, or the
      Transaction → New
      menu item in the  menu, to open a register window and enter the missing
      transaction. The new item will appear in the Reconcile window when you
      press the Enter button in the register after entering the transaction.
When you find the item in the Reconcile window, compare the amount
      in the item to the amount on the statement. If they disagree, you may
      have made an error when you entered the transaction in GnuCash. You can
      use the Edit button on the Toolbar, or the
      Transaction → Edit
      item, to open a register window and correct the transaction.
If the amounts agree, click on the item in the Reconcile window.
      A check mark wil appear in the R column aside the selected transaction.
      GnuCash will automatically update the amounts in the lower right summary pane.
Tip
You can use the up/down arrow keys to scroll to the item, the
        space key to mark the item as reconciled and the Tab
        key to switch panes.

You then repeat this for each item that appears on the bank
      statement, verifying that the amounts match with the amounts in GnuCash,
      and marking off transactions in GnuCash as they are reconciled.
Tip
You can check or uncheck the reconcile status of all transactions in 
       either pane by clicking on a transaction in the required pane then clicking 
       Ctrl-A followed by space. This will toggle 
       the reconcile status of all transactions in the pane to either checked or 
       unchecked state. This procedure can be repeated to achieve the desired status 
       for the transactions in the pane.

At the bottom of the Reconcile window there is a Difference field,
      which should show 0.00 when you are done reconciling. If it shows some
      other value, then either you have missed transactions, or some amounts
      may be incorrect in GnuCash. (Or, less likely, the bank may have made an
      error.)
Note
Under some circumstances, it may be difficult or impossible to determine why an account will not reconcile. If you are unable to correct the discrepancy between your books and a statement, GnuCash includes a Balance button on the Toolbar that will automatically create a balancing entry for you in the amount that cannot be reconciled.
To use this, carry out the full reconciliation (marking all transactions that you can identify) and then click this button. GnuCash will create a balancing entry for the remaining discrepancy that uses the Special Accounts:Orphan-XXX account (where "XXX" represents your currency). The Reconcile window will close; re-opening it will allow you to check the newly-created balancing entry and finish the process.

When you have marked off all the items on the bank statement and the difference is 0.00, press the Finish button on the Toolbar or
      select Reconcile → Finish from the menu.
      The Reconcile window will close.
      In the register window, the R field of the reconciled transactions will
      change to y.
In this case, we have not received all the information yet, so we
      simply press the Postpone button, so we can continue at
      a later stage. Observe that the R column indicates we cleared (c)
      two transactions. They have not been reconciled yet, but we have
      verified these two transactions so they have been marked as cleared. If
      you look at the Statusbar at the bottom of the account register, you
      will see a summary of what has been reconciled and what has been cleared
      (Cleared:USD 954.79 Reconciled:USD 0.00)
[image: Checking account]The Checking account after postponing the
          reconciliation.





Accounts Payable



Accounts Payable (or A/P) refers to the accounting of products or services which a company has
        bought and needs to pay for.
System Components



GnuCash has an integrated accounts payable system. The transactions generated by the A/P system are placed within the Accounts Payable account,
           as a record of what occurs. Generally you do not directly work with this account but use the four integrated GnuCash A/P application components.
           The A/P components are available from the Business → Vendor sub-menu. These A/P components are:
        
	Vendors are people or companies from which you buy products or services on credit.

	Bills represent the physical bills vendors send to request payment from you. A bill contains an itemized list of things you purchased.
In addition, GnuCash also has support for Credit Notes
                 which represent the inverse of Bills. A credit note is usually received from
                 a vendor to correct items that were erroneously billed or returned.
              
Both document types will be set up using the same menu items.

	Jobs (optional) is where you register Vendor Jobs. Jobs are mechanism by which you can group multiple bills from a particular vendor.
              

	Process Payments is where you register payments to a vendor to whom you owe money.



The following sections introduce the individual Accounts Payable application components.

Vendors



A vendor is a company or person from whom you purchase goods or services. Vendors must be registered within the A/P system.
New



To register a new vendor, select the Business → Vendor → 
              New Vendor menu item. Fill in general information about the vendor, such as Company Name, Address, Phone,
           Fax, etc. Below is a list of the other options: 
This is what the New Vendor registration window looks like:
           
Figure 13.17. New Vendor Registration Window
[image: New Vendor Registration Window]





Find and Edit



To search for an existing vendor, use the Business → Vendor → 
              Find Vendor window. You select a vendor to View/Edit from the results of the search.
              This window is also used to look up a vendor when entering bills and processing payments.
            
Figure 13.18. Find Vendor Window
[image: Find Vendor Window]




If many vendors match the search criteria you provide, the
              search can be refined by running an additional search within the current
              results. The current result set is searched when the Refine
                 Current Search radio button is selected. In fact, GnuCash
              selects this option for you after you run the initial search.
If the vendor you are searching for does not match the supplied
              search criteria, change the search criteria, click the New
                 Search radio button and then the Find
              button. The relevant step is the New Search
              selection. If the vendor is not in the result of the original search,
              and you only search within this set, the vendor cannot be found,
              regardless of new search criteria.
           
Note
To return a list of all registered active vendors, set the search criterion to matches regex, and place a single dot “.” in the text field area. Make sure Search only active data is checked, then click Find. The regular expression “.” means to match anything.
              



Bills



A bill is a request for payment you receive from a vendor. GnuCash can track bills.
A credit note is the document you receive from a vendor to correct
           products or services rendered that you were incorrectly charged for on a bill. GnuCash can generate and track
           credit notes via the same menu entries as bills.
Note
This section applies to both bills and
              credit notes. In order to avoid repeating everything twice and to keep
              the text easier to read it will refer only to bills. You can apply
              it equally to credit notes. Only where the behaviour of credit notes
              differs from bills this will be explicitly mentioned.

New



When you receive a bill from a vendor and want to enter it into GnuCash, you must create a new bill. To create a new bill use the Business → Vendor → New Bill menu item, and fill in the resulting window appropriately.
Figure 13.19. New Bill Registration Window
[image: New Bill Registration Window]




When you click the OK button the Edit Bill window opens.

Edit



From the Edit Bill window you can enter an itemized list of
              goods and services you purchased, in a manner similar to how the account
              register works. For credit notes you enter an itemized list of goods and
              services the vendor refunded instead.
           
Figure 13.20. Edit Bill Window
[image: Edit Bill Window]




When you have finished entering all the items, Post the bill. 

Post



When you finish editing a bill, you should Post the bill. You do not have to post the bill,
              you can close it and return to it later. You have to post the bill eventually. Posting a bill places its transactions into an accounts payable account.
              The Post Bill window appears and asks you to enter information:
           
Figure 13.21. Post Bill Window
[image: Post Bill Window]





Find



To find an existing bill, use the Business → Vendor → Find Bill menu item. From the results of the search, you can select a bill to edit, or view.
Note
Before you can edit a posted bill, you will need to Unpost it.

Note
There are other ways to access an existing bill. These are similar to accessing invoices for your customers. See the section called “Find” for more information.



Vendor Jobs



Vendor Jobs are used to group multiple bills and credit notes from a single vendor. Use of the vendor jobs feature is optional.
           The feature is useful when you have multiple jobs for the same vendor, and would like to view all the bills and
           credit notes for a single job.
        
To use vendor jobs, you must create them using the
           Business → Vendor → New Job menu item. You will see the New Job window.
        
Figure 13.22. New Vendor Job
[image: New Vendor Job]




To edit an existing vendor job, use the Business → Vendor → Find Job menu item. Select the desired job in the
        search results, and click the View/Edit Job
           button.
To select from the bills associated with a given job, use Business → Vendor → Find Job menu item. Select the desired job in the
        search results and click the View Invoices button. A
        window listing bills and credit notes associated with this job appears. Select a
        bill or credit note and click the View Invoice button to open a
           bill editor in the main application window.

Process Payment



Eventually, you need to pay your bills. To do so, use the Process Payment application found in
           Business → Vendor → Process Payment.
        
Below is the GnuCash Accounts Payable payment window.
Figure 13.23. Process Vendor Payment
[image: Process Payment to Vendor]Process Payment to Vendor
                 








Process Payment



Eventually, you will receive payment from your customers for
    outstanding invoices. To register these payments, use the Process Payment
    application found in Business → Customer → Process
    Payment.
[image: Process Payment]Process Payment Window 




About this Book



This manual’s goal is to save you time. It will get you started
    using GnuCash as quickly as possible.
Each chapter follows a simple format. A chapter begins with a
    “Concepts” discussion which introduces general themes and
    terminology, addressed and used within that chapter. “How-To”
    sections, which address specific procedures follow. Finally, a
    “Putting It All Together” section ends the chapter by giving
    detailed, concrete examples.
Beginning users will find the “Concepts” sections very
    helpful. They provide a reference for good ways to track your finances,
    and serve as a general introduction to financial background and
    terminology. Experienced users can flip to the “How-To”
    sections to quickly scan procedures. These sections provide to-the-point
    steps for accomplishing specific tasks. The “Putting It All
    Together” sections present real-world examples in the form of a
    tutorial. Beginning with creation of a file in Chapter 2, The Basics,
    each successive chapter builds on the previous chapter’s tutorial.
This manual is organized into 3 main parts: 
	Getting Started

	Managing Personal Finances

	Managing Business Finances



Getting Started provides you with the most
        basic information needed to begin using GnuCash. The chapters in this section explain concepts that are fundamental to using GnuCash. New users of GnuCash should familiarize themselves with the information in these chapters to get you up and running: 
	Chapter 1, Overview - (this chapter) gives a general overview of GnuCash

	Chapter 2, The Basics - gives users a very brief introduction to accounting principles, and then provides information about how GnuCash structures its data. There is also information on basic interface elements in GnuCash. Finally, this chapter explains how GnuCash stores and manages your data.

	Chapter 3, Accounts - gives further information about accounts and how to organize them.

	Chapter 4, Transactions - gives basic information about transactions and how to enter them.



Managing Personal Finances addresses
    common applications and features of GnuCash in greater detail. You will
    see more specific cases, based on frequently asked questions about
    applying GnuCash to everyday situations. Here are the applications and
    features covered in this part: 
	Chapter 5, Checkbook

	Chapter 7, Credit Cards

	Chapter 8, Loans

	Chapter 9, Investments

	Chapter 11, Capital Gains

	Chapter 12, Multiple Currencies



Managing Business Finances discusses the
    use of GnuCash in business accounting: 
	Chapter 13, Business Features

	Chapter 14, Budgets

	Chapter 15, Other Assets

	Chapter 16, Depreciation

	Chapter 17, Python Bindings

	Chapter 18, Importing Business Data



This manual also includes several appendices, which contains extra information
    you might want to know:
	GnuCash Glossary - Glossary of terms used in GnuCash

	Appendix A, Migration Guide - Guide for former Quicken®, MS Money or other QIF
        users

	Appendix B, Frequently Asked Questions

	Appendix C, Contributed Account Trees

	Appendix D, Auxiliary File Formats

	Appendix E, GNU Free Documentation License



Last, but not least, a glossary and index help you quickly locate
    topics.

Checking QIF Data (Discussion)




 

Chapter 18. Importing Business Data



Import Bills or Invoices



This functionality is only available by default for versions greater than 2.6
For 2.4.13 the Customers and Vendors importer is an optional module and needs to enabled by editing the file $HOME/.gnucash/config.user,
    adding the line:
(gnc:module-load "gnucash/plugins/bi_import" 0)
On Linux systems this file is found at $HOME/.gnucash/config.user
      and on Mac OSX it is ~/Library/Application Support/Gnucash/config.user.
      If the file doesn’t already exist you will have to create it.
      After restarting GnuCash, the item will appear at the bottom
    of the business menu.
In order for the importer to work the data must be in a fixed field
      length, comma separated line format. A example Python script to convert
      a downloaded order is shown below.
    

      

import sys
import csv

VENDOR_ID="000013"
INFILE=sys.argv[1]
INV_ID=sys.argv[2]
try:
  ACCOUNT=sys.argv[3]
except:
  ACCOUNT="Expenses:Materials General"

Reader = csv.reader(open(INFILE), delimiter=',')

# Need to ignore 1st and last rows

for row in Reader:
  if row[0].isdigit(): # We only use numbered lines
    outline=(INV_ID + ",," + VENDOR_ID + ",,,," + row[1] + " > " + row[4] + ",ea," +
      ACCOUNT + "," + row[2] + "," + row[5].replace("GBP", "") + ",,,,no,,,,,,,")
  print outline
      

    
Example of a downloaded vendor order from Rapid Electronics (UK).
      

line number,product code,quantity,availability,product description,unit price,discounts,line total,delivery,sub total,vat,grand total
1,47-3524,100,100 Available,BC848C SOT-23 NPN TRANSISTOR (INF) (RC),GBP0.03,GBP0.00,GBP0.03
2,47-3278,30,30 Available,L78L05ACZ 0.1A +5V VOLTAGE REG (ST) (RC),GBP0.18,GBP0.00,GBP0.18
3,22-0120,1,1 Available,Tube 34 14pin DIL socket, narrow7.62mm, without central support,GBP1.05,GBP0.00,GBP1.05
4,22-0127,1,0 Available<br />1 on Back Order,Tube 17 28pin DIL socket, wide15.24mm, without central support,GBP1.22,GBP0.00,GBP1.22
5,62-0368,1,1 Available,820R CR25 0.25W CF Resistor Pk 100,GBP0.50,GBP0.00,GBP0.50
6,47-3130,100,100 Available,1N4001 1A 50V SILICON RECTIFIER DIODE RC,GBP0.01,GBP0.00,GBP0.01
7,17-0310,1,1 Available,PROFESSIONAL MINATURE PROBE HOOK RED RC,GBP0.90,GBP0.00,GBP0.90
8,17-0312,1,1 Available,PROFESSIONAL MINATURE PROBE HOOK BLACKRC,GBP0.90,GBP0.00,GBP0.90
9,34-0655,1,1 Available,PROTOBLOC 2 BREADBOARD,GBP4.39,GBP0.00,GBP4.39
10,18-0200,1,1 Available,PP3 9V ALKALINE BATTERY "Not For Retail Sale",GBP1.37,GBP0.00,GBP1.37
,,,,,,,,GBP4.95,GBP24.93,GBP4.35,GBP29.28
      

    
A similar file after processing with the Python script.

        

MEC-0071,,000013,,,,34-0655 > PROTOBLOC 2 BREADBOARD,ea,Expenses:Materials General,1,4.39,,,,no,,,,,,,
MEC-0071,,000013,,,,18-0105 > PP3 / PP6 BATTERY CLIP 150MM (RC),ea,Expenses:Materials General,10,0.06,,,,no,,,,,,,
MEC-0071,,000013,,,,62-0370 > 1k CR25 0.25W CF Resistor Pk 100,ea,Expenses:Materials General,1,0.50,,,,no,,,,,,,
MEC-0071,,000013,,,,62-0354 > 220R CR25 0.25W CF Resistor Pk 100,ea,Expenses:Materials General,1,0.50,,,,no,,,,,,,
MEC-0071,,000013,,,,34-5548 > PLAIN DOCUMENT WALLET ASSORTED PK 50 RE,ea,Expenses:Materials General,1,6.95,,,,no,,,,,,,
MEC-0071,,000013,,,,62-0386 > 4k7 CR25 0.25W CF Resistor Pk 100,ea,Expenses:Materials General,1,0.50,,,,no,,,,,,,
MEC-0071,,000013,,,,34-0860 > COPPER CLAD SRBP SS 100 X 160 (RC),ea,Expenses:Materials General,5,0.50,,,,no,,,,,,,
MEC-0071,,000013,,,,18-0163 > PP3 BATTERY HOLDER WITH FLYING LEADS RC,ea,Expenses:Materials General,5,0.23,,,,no,,,,,,,
MEC-0071,,000013,,,,73-4290 > ATMEGA8-16PU 8-BIT MICRO 8K DIL-28 (RC),ea,Expenses:Materials General,3,1.99,,,,no,,,,,,,
MEC-0071,,000013,,,,81-0014 > BC108 NPN GP TRANSISTOR RC,ea,Expenses:Materials General,20,0.16,,,,no,,,,,,,
MEC-0071,,000013,,,,DELIVERY,ea,Expenses:Postage,1,4.95,,,,no,,,,,,,
MEC-0071,,000013,,,,VAT,tax,Expenses:VAT,1,4.35,,,,no,,,,,,,
        

    

      As can be seen there are some fields that are absent and some that
      are not required for import. The first line is not required and the last
      line is superfluous as GnuCash will total the order for us. All that is
      required is to take what we want and produce an output file with the
      correct format to import into GnuCash. In this case we join the part
      number and description fields and these become description in GnuCash
      invoice/bill. We need the qty and part price fields. Contrary to the
      header line VAT is not included by line and is always zero, the VAT is
      calculated on the last line as VAT on the order total.
      
Note
This will cause problems later.


      In this example I have assigned the
      Expenses:Materials General account to be the target account. This can be
      changed after import in the usual way, along with any other data. If there
      is no such account as Expenses:Materials General then that field will be
      left blank on import and will have to be set manually. Lines beginning
      with a “#” are regarded as comment lines and ignored.
    
The script is called with the following command:
 python importer.py file_to_import,
      invoice_id > file_to_save_as.csv
      
This short script can easily be
      changed to suit any downloaded format. The only restriction is that the
      final number of field is fixed, at least at the moment. The importer will
      ignore lines with the wrong number of fields. (This may be fixed in future
      version). Vendor ID is simply the ID assigned to the specific vendor, or
      client. The row[N] items refer to the position in the line where the
      correct data lies. Note that the first field is row[0] NOT row[1].
    
Once you have converted the file navigate to Business → Invoice & Bill Import to open a new import window.
      Select the file you have just created, select Bill
      or Invoice and Comma separated format. At this
      point the data should show up in the preview window. Check that the field
      data are in the correct columns before selecting OK. Once imported the
      invoice can be opened for editing and posting in the usual way.
    
A note on VAT, or any purchase tax. As previously mentioned Rapid
      Electronics calculate the VAT on the bill total not line by line. GnuCash
      calculated the VAT per line then totals the VAT. This can lead to
      inaccuracies in the VAT of the region of a few pennies and is enough to
      cause problems when reconciling the purchase with your bank or credit card
      account used to make the purchase. As to how you overcome that, for the
      moment, is a problem for you to use whatever method suits your conscience
      or accountant best. Personally I add the VAT as a separate line along with
      delivery charges manually. So some work is left to the user but the tedium
      of entering each item eliminated.
    
Future: Currently the import format is quite strict and many users
      may have problems with the conversion process. Adding a template for every
      possible vendor CSV format would be mammoth and likely impossible task
      notwithstanding the fact the vendors are likely to change the format
      without informing the GnuCash team. Future import enhancements will be
      based on user feedback and hopefully the process can be made simpler or
      more flexible. Note that often “simple” is incompatible with
      “flexible”.
    
Note
If Python (other languages are avaialble) is not your thing then
      post a request to GnuCash user list,
      with an example of your downloaded CSV, and someone may write you a Python script to do the
      translation.
    

Notes for Python authors



In order for the import to succeed the number of fields must be
        adhered to, so the trailing commas are important.
      
A complete list of the required fields is:
id, date_opened, owner_id, billingid, notes, date, desc, action,
        account, quantity, price, disc_type, disc_how, discount, taxable,
        taxincluded, tax_table, date_posted, due_date, account_posted,
        memo_posted, accu_splits,
      
Note
Mind the trailing comma.


A brief description of each field



	id -
            The invoice number. All lines must
            contain this or the line will be rejected.
          

	date_opened -
             Use the same date format as setup in Preferences. Today's date is inserted if this is blank.
          

	owner_id -
            ID number of the vendor or customer. All lines must
            contain this or the line will be rejected.
          

	billingid -
            Billing ID.
          

	notes -
            Invoice notes.
          

	date -
            The date of the item line. Can be left blank for todays
            date.
          

	desc -
            Description as per normal invoice or bill.
          

	action -
            For bills usually “ea”.
          

	account -
            Account to which the item is attributed.
          

	quantity -
            Quantity of each item. Must contain a value or the line
            will be rejected.
          

	price -
            Price of each item. Must contain a value or the line will be
            rejected.
          

	disc_type -
            Type of discount, either “%” or “TODO”, only applies to
            invoices. Some experimentation may be required here as may be currency
            dependent.
          

	disc_how -
            Only applies to invoices.
          

	discount -
            Amount of discount to be applied. only applies to
            invoices.
          

	taxable -
            Will tax be applied to the item? “yes” or blank.
          

	taxincluded -
            Is tax included in the item price? “yes” or blank.
          

	tax_table -
            Tax table to apply to item.
          

	date_posted -
            If posted, what date. Normally left blank for manual
            posting after editing the invoice.  Use the same date format as setup in Preferences.
          

	due_date -
            Date payment is due.   Use the same date format as setup in Preferences.
          

	account_posted -
            Posted to what account.
          

	memo_posted  -
            If posted insert memo here.
          

	accu_splits -
            Accumulate splits? “yes” or blank.
          






Calculations



Determining loan amortization schedules, periodic payment amounts,
    total payment value, or interest rates can be somewhat complex. To help
    facilitate these kinds of calculations, GnuCash has a built-in
    Loan Repayment Calculator. To access the calculator, go to Tools → Loan Repayment Calculator.
[image: Loan Repayment Calculator]The GnuCash Loan Repayment Calculator.



The Loan Repayment Calculator can be used to calculate any one of the
    parameters: Payment Periods, Interest
    Rate, Present Value, Periodic
    Payment, or Future Value given that the
    other 4 have been defined. You will also need to specify the compounding
    and payment methods.
	Payment Periods - the number of payment
        periods.

	Interest Rate - the nominal interest rate
        of the loan, ie: the yearly interest rate.

	Present Value - the present value of the
        loan, ie: current amount owed on the loan.

	Periodic Payment - the amount to pay per
        period.

	Future Value - the future value of the
        loan, ie: the amount owed after all payment periods are over.

	Compounding - two interest compounding
        methods exist, discrete or continuous. For discrete compounding select
        the compounding frequency from the popup menu with a range from yearly
        to daily.

	Payments - the popup menu allows you to
        select the payment frequency with a range from yearly to daily. You
        can also select whether your payments occur at the beginning or end of
        the period. Payments made at the beginning of the payment period have
        interest applied to the payment as well as any previous money paid or
        money still owed.



Example: Monthly Payments



What is your monthly payment on a $100000 30 year loan at a fixed
      rate of 4% compounded monthly?
This scenario is shown in the example image above. To perform this
      calculation, set Payment Periods to 360 (12 months x 30 years), Interest
      Rate to 4, Present Value to 100000, leave Periodic Payment empty and set
      Future Value to 0 (you do not want to owe anything at the end of the
      loan). Compounding is Monthly, Payments are Monthly, assume End of
      Period Payments, and Discrete Compounding. Now, click on the
      Calculate button next to the Periodic Payment
      area. You should see $-477.42.
Answer: You must make monthly payments of 477.42.

Example: Length of Loan



How long will you be paying back a $20000 loan at 10% fixed rate
      interest compounded monthly if you pay $500 per month?
To perform this calculation, leave Payment Periods empty, set
      Interest Rate to 10, Present Value
      to 20000, Periodic Payment is -500,
      and Future Value is 0 (you do not want to owe anything
      at the end of the loan). Compounding is Monthly,
      Payments are Monthly, assume End
      of Period payments, and Discrete Compounding.
      Now, click on the Calculate. You should see 49 in the
      Payment Periods field.
Answer: You will pay off the loan in 4 years and 1 month (49 months).

Advanced: Calculation Details



In order to discuss the mathematical formulas used by the
      Loan Repayment Calculator, we first must define some
      variables.



 n  == number of payment periods

 %i  == nominal interest rate, NAR, charged

 PV  == Present Value

 PMT == Periodic Payment

 FV  == Future Value

 CF == Compounding Frequency per year

 PF == Payment Frequency per year



Normal values for CF and PF are:

   1   == annual

   2   == semi-annual

   3   == tri-annual

   4   == quaterly

   6   == bi-monthly

   12  == monthly

   24  == semi-monthly

   26  == bi-weekly

   52  == weekly

   360 == daily

   365 == daily




      
Converting between nominal and effective interest rate



When a solution for n, PV, PMT or FV is required, the nominal
        interest rate (i) must first be converted to the effective
        interest rate per payment period (ieff). This rate,
        ieff, is then used to compute the selected variable. When a solution
        for i is required, the computation produces the effective interest
        rate (ieff). Thus, we need functions which convert from i to ieff, and
        from ieff to i.


To convert from i to ieff, the following expressions are used:

Discrete Interest:     ieff = (1 + i/CF)^(CF/PF) - 1

Continuous Interest: ieff = e^(i/PF) - 1 = exp(i/PF) - 1



To convert from ieff to i, the following expressions are used:

Discrete Interst:      i = CF*[(1+ieff)^(PF/CF) - 1]

Continuous Interest: i = ln[(1+ieff)^PF]



Note
NOTE: in the equations below for the financial transaction,
          all interest rates are the effective interest rate, “ieff”. For the
          sake of brevity, the symbol will be shortened to just “i”.


The basic financial equation



One equation fundamentally links all the 5 variables. This is
        known as the fundamental financial equation:


PV*(1 + i)^n + PMT*(1 + iX)*[(1+i)^n - 1]/i + FV = 0



  Where: X = 0 for end of period payments, and

         X = 1 for beginning of period payments



From this equation, functions which solve for the individual
        variables can be derived. For a detailed explanation of the derivation
        of this equation, see the comments in the file src/calculation/fin.c
        from the GnuCash source code. The A, B, and C variables are defined
        first, to make the later equations simpler to read.


A = (1 + i)^n - 1

B = (1 + iX)/i

C = PMT*B



n = ln[(C - FV)/(C + PV)]/ln((1 + i)

PV = -[FV + A*C]/(A + 1)

PMT = -[FV + PV*(A + 1)]/[A*B]

FV = -[PV + A*(PV + C)] 



The solution for interest is broken into two cases.

The simple case for when  PMT == 0 gives the solution:

i = [FV/PV]^(1/n) - 1





The case where PMT != 0 is fairly complex and will not be
        presented here. Rather than involving an exactly solvable function,
        determining the interest rate when PMT !=0 involves an iterative
        process. Please see the src/calculation/fin.c source file for a
        detailed explanation.

Example: Monthly Payments



Let’s recalculate the section called “Example: Monthly Payments”,
        this time using the
        mathematical formulas rather than the Loan Repayment Calculator. What is
        your monthly payment on a $100000 30 year loan at a fixed rate of 4%
        compounded monthly?
First, let’s define the variables: n = (30*12) = 360, PV =
        100000, PMT = unknown, FV = 0, i = 4%=4/100=0.04, CF = PF = 12, X = 0
        (end of payment periods).
The second step is to convert the nominal interest rate (i) to
        the effective interest rate (ieff). Since the interest rate is
        compounded monthly, it is discrete, and we use: ieff = (1 +
        i/CF)^(CF/PF) - 1, which gives ieff = (1 + 0.04/12)^(12/12) - 1, thus
        ieff = 1/300 = 0.0033333.
Now we can calculate A and B. A = (1 + i)^n - 1 = (1 +
        1/300)^360 - 1 = 2.313498. B = (1 + iX)/i = (1 + (1/300)*0)/(1/300) =
        300.
With A and B, we can calculate PMT. PMT = -[FV + PV*(A +
        1)]/[A*B] = -[0 + 100000*(2.313498 + 1)] / [2.313498 * 300] =
        -331349.8 / 694.0494 = -477.415296 = -477.42.
Answer: You must make monthly payments of 477.42.



Chapter 4. Transactions



This chapter will give you the basic information you need to
  understand and use transactions in GnuCash. Whereas accounts are the
  framework and structure of a chart of accounts, transactions are the data
  which fills each account.
Basic Concepts



A transaction in a double entry accounting
    system such as GnuCash is an exchange between at least 2 accounts. Thus, a
    single transaction must always consist of at least two parts, a from and
    a to account. The from account is transferring value to the to account.
    Accountants call these parts of a transaction Ledger
    Entries. In GnuCash, they are called
    Splits.
A split identifies the account to which it refers, the
    amount of money specifically moved to or from that account, and
    can contain a few other specific pieces of information if needed.
    GnuCash supports multiple splits in a
    single transaction, and the splits can move money into or out of
    the involved accounts arbitrarily.
For example, you receive a paycheck and deposit it into your savings
    account at the bank. The transaction that occurs is
    that your bank savings account (an asset) received money from your income
    account. Two accounts are affected, and in this case there is a net
    increase in your equity.
Working with transactions in GnuCash is performed using what is
    known as the account register. Every account you
    create has an account register. It will appear familiar to you as it looks
    very similar to the log used to track checkbooks.
The account register is explained in the upcoming section,
    the section called “The Account Register”.


Appendix A. Migration Guide




This appendix is to help current users of other financial software packages in their migration to GnuCash.  We address the conceptual differences between the layout of GnuCash accounts versus other software packages.
  
Using Accounts vs. Categories




If you are familiar with other personal finance programs, you are already accustomed to tracking your income and expenses as categories. Since GnuCash is a double-entry system (refer to section 2.1), income and expenses are tracked in accounts. The basic concept is the same, but the account structure allows more consistency with accepted business practices. So, if you are a business user as well as a home user, GnuCash makes it easy to keep track of your business as well as your personal accounts.


Income and expense accounts give you the same information you would get with categories, but they also give you more flexibility in entering your transactions.    In GnuCash, you have the option to enter transactions directly into income and expense accounts through their account registers.   Other programs that use categories do not offer this option, because there is no “account register” for a category.


You also have the option in GnuCash to treat income and expense accounts exactly as you would treat categories, if you are more comfortable with that method.  In Quicken® and similar programs,  transactions require an account and a category.   Substitute an income or expense account name in GnuCash where you would normally enter a category name in the other programs, and the result should be the same.   We will discuss transaction entry in Chapter 4 in greater detail.



Chapter 14. Budgets




 This chapter explains how to create and use budgets with GnuCash.
  
Basic Concepts



A budget is a tool for estimating expected income and expenses.
 You can use it to help you plan how you intend for your finances to
 change over a period of time, and to examine how your actual
 financial transactions for the period compare to your planned
 transactions.
The budgeting concept is quite general, so GnuCash offers a
budgeting tool that is both simple and flexible.  You, the user, have
to decide how complex or simple you want to make your budget.  This
guide will help you make some of those decisions.
Terminology



There are a few helpful terms listed
  below that will be used to discuss budgeting.
	Budget - A financial plan describing
    the expected revenues and/or disbursements for a particular time
    period

	Cash Budget - A budget planning for
    expected cash receipts and cash disbursements.  This type of
    budget tracks cash flow -- where your money comes from, where it
    goes, and, of course, how much.

	Expense Budget - A budget chiefly for
    planning what you spend your money on.  This type of budget tracks
    your expenses.  It is typically not concerned with things like
    appreciation or repayment of liabilities.  However, it would
    account for interest charges.  For example, if you buy $100 worth
    of groceries with your credit card, you incur an $100 expense for
    groceries, and a $100 liability to your credit card company.  When
    you pay the credit card bill for $110, you are incurring an
    additional interest expense of $10.  An expense budget plans for
    the transaction of buying the groceries and paying the interest,
    but not the transaction of repaying the credit card
    company.

	Capital Budget - A budget that
    describes a plan for paying for a large future expense, often
    through a combination of saving and borrowing money.  Note:
    Capital budgets can sometimes get quite complex because they can
    try to answer the question "Can we afford to do such-and-such?" by
    exploring various hypothetical scenarios that can involve
    hypothetical accounts.  

	Budget Period - The period of time
    during which the plan is expected to take place.  The most common
    budget periods are annual and monthly.  Sometimes, you may budget
    for several consecutive periods at once, for convenience or for
    finer-grained planning.  For example, an annual budget may include
    12 monthly budget periods.






Entering Withdrawals



When you withdraw money from your bank account, for whatever reason,
    you are transferring money from your bank account to some other location.
    In GnuCash, this other location is tracked as an account. The more
    detailed accounts you create and use for your spending, the more
    information you will get about where your money goes.
Withdrawals take many forms. ATM withdrawals are one of the most
    common transactions. Writing checks is one way to withdraw money to pay
    bills, to buy purchases, or to give to charity. Depending on your bank,
    you might also have service charges, where the bank withdraws the money
    from your account. Transfers of money out to another account are also
    withdrawals. We will take a look at each of these types of withdrawals and
    how to record them in GnuCash.
ATM/Cash Withdrawals



Cash withdrawals are handled as a transfer from a bank account to
      a cash account. GnuCash provides special Cash type
      accounts for tracking your cash purchases, so you should set up a cash
      account to record your ATM and other cash withdrawals.
Cash accounts can be used for different levels of detail. On a
      basic level of detail, you simply transfer money to it from your
      checking account. That tells you how much money you took out of checking
      on a given day, but it doesn’t tell you where that cash was spent. With
      a little more effort, you can use the cash account to record your cash
      purchases as well, so that you can see where that cash went. You record
      these purchases as a transfer from the cash account to expense
      accounts.
Some people record every cash purchase, but this takes a lot of
      work. An easier way is to record the purchases for which you have
      receipts, but then adjust the balance of the account to match what is in
      your wallet.
It’s a good idea to at least set up a cash account for your
      withdrawals. Then if you decide to track where your cash goes, you can
      enter transactions for the money you spend. You determine what level of
      detail you want to use.


Setting Up Accounts



To begin managing your credit cards in GnuCash, you should set up a
    Liability top level account and under this parent account create credit
    card type accounts for each credit card you use. If you are tracking only
    the payments you make to the credit card company, then all you need is a
    bank account and a credit card account to enter your transactions.
The charges you make on your credit card are expenses, so you will
    have to set up these accounts under the top-level account called
    Expenses. If you decide to keep a more detailed records of your
    purchases, you will need to create expense accounts for each kind of
    purchase you make. Since you will also be reconciling the balance to your
    credit card statements, you should also enter an opening balance in each
    credit card account. The easiest way to do this is to use your last
    statement balance as the opening balance.
Simple Setup



If you do not want to track each expense made on the credit card,
      you can set up a simple account hierarchy like this:


-Assets

   -Bank

-Liabilities

   -Credit Card

-Expenses

   -Credit Card

   

In this example, if you enter your total amount charged per month
      as a transaction between Liabilities:Credit Card and
      Expenses:Credit Card. When you make a payment, you would
      enter a transaction between Assets:Bank and
      Liabilities:Credit Card.
The obvious limitation of this simple credit card setup is that
      you cannot see where your money is going. All your credit card expenses
      are being entered in the Credit Card expense account. This is, however,
      very simple to set up and maintain.

Complete Setup



If you want to track your expenses more completely, you should
      set up multiple expense accounts named for the various kinds of expenses
      you have. Each charge on your credit card is then entered as a separate
      transaction between your Credit Card liability account and a specific
      expense account. Below is an example of an account hierarchy for
      this:


-Assets

    -Bank

-Liabilities

    -Credit Card

-Expenses

    -Food

    -Car

    -Clothes

    -Entertainment

    -Interest

    -Service

   

Clearly, you should enter specific expense accounts which fit your
      spending habits. The only difference with this setup as compared to the
      simple setup is that the expenses have been subdivided by groups. Also
      notice that there is an “Interest” expense, this is used for when your
      credit card charges interest on your monthly unpaid balance. The
      “Service” expense account is used to track service expenses associated
      with the credit card, such as the yearly usage fee if it exists. With
      this setup, you will be able to see where your money goes every month,
      grouped according to the expense accounts.
The rest of this chapter will assume you are using the complete
      setup.


Example



Let’s suppose you buy an asset expected to increase in value, say a
    Degas painting, and want to track this. (The insurance company will care
    about this, even if nobody else does.)
Start with an account hierarchy similar to that shown in the section called “Account Setup”, but replace “ITEM1” with “Degas” and you
    can remove the “ITEM2” accounts. We will assume that the Degas painting
    had an initial value of one hundred thousand dollars. Begin by giving your
    self $100,000 in the bank and then transferring that from your bank
    account to your Assets:Fixed Assets:Degas:Cost account (the asset
    purchase transaction). You should now have a main account window which
    appears like this:
[image: Asset Appreciation Main Window]The asset appreciation example main window
        



Unrealized Gains



A month later, you have reason to suspect that the value of your
      painting has increased by $10,000 (an unrealized gain). In order to
      record this you transfer $10,000 from your Accrued Gains income account
      (Income:Unrealized Gains) to your asset Unrealized Gains account
      (Assets:Fixed Assets:Degas:Unrealized Gain). Your main window will
      resemble this:
[image: Asset Appreciation Main Window]Chart of Accounts after unrealized
          gain




Selling



Let’s suppose another month later prices for Degas paintings have
      gone up some more, in this case about $20,000, you estimate. You duly
      record the $20,000 as an unrealized income like above, then decide to
      sell the painting.
Three possibilities arise. You may have accurately
      estimated the unrealized gain,
      underestimated the unrealized gain, or
      overestimated the unrealized gain.
	Accurate estimation of unrealized
          gain.
Your optimistic estimate of the painting’s value was correct.
          First you must record that the profits made are now realized gains,
          not unrealized gains. Do this by transferring the income from the
          Income:Unrealized Gains to the 
          Income:Realized Gains account.
Secondly, you must credit your bank account with the selling
          price of the painting. This money comes directly from your
          Assets:Fixed Assets:Degas sub-accounts. Transfer the full
          Assets:Fixed Assets:Degas:Cost value into 
          Assets:Current Assets:Savings Account, and the full 
          Assets:Fixed Assets:Degas:Unrealized Gain into 
          Assets:Current Assets:Savings Account.
These transactions should now appear as follows:
Table 10.1. Turning an Accrued Gain into a Realized Gain
	Account	Transfer to	Transaction Amount	Account Total
	Income:Unrealized Gains	Income:Realized Gains	$30,000	$0
	Assets:Fixed Assets:Degas:Cost	Assets:Current Assets:Savings Account	$100,000	$0
	Assets:Fixed Assets:Degas:Unrealized Gains	Assets:Current Assets:Savings Account	$30,000	$0





This leaves the Assets:Current Assets:Savings Account account
          with a total of $130000 and Income:Realized Gains with a total of
          $30000.
[image: Asset Appreciation Main Window]Chart of Accounts after realized
              gain




	Under estimation of unrealized
          gain.
You were over-optimistic about the value of the painting.
          Instead of the $130000 you thought the painting was worth you are only
          offered $120000. But you still decide to sell, because you value
          $120000 more than you value the painting. The numbers change a
          little bit, but not too dramatically.
The transactions should now appear as follows (observe the
          last transaction which balances the Unrealized Gains
          accounts):
Table 10.2. Turning an Accrued Gain into a Realized Gain
	Account	Transfer to	Transaction Amount	Account Total
	Income:Unrealized Gains	Income:Realized Gains	$20,000	$10,000
	Assets:Fixed Assets:Degas:Cost	Assets:Current Assets:Savings Account	$100,000	$0
	Assets:Fixed Assets:Degas:Unrealized Gains	Assets:Current Assets:Savings Account	$20,000	$10,000
	Assets:Fixed Assets:Degas:Unrealized Gains	Income:Unrealized Gains	$10,000	$0





This leaves the Assets:Current Assets:Savings Account account
          with a total of $120000 and Income:Realized Gains with a total of
          $20000.

	Over estimation of unrealized
          gain.
You manage to sell your painting for more than you thought in
          your wildest dreams ($150,000). The extra value is, again, recorded
          as a gain, i.e. an income.
The transactions should now appear as follows (observe the
          last transaction which balances the Unrealized Gains
          accounts):
Table 10.3. Turning an Accrued Gain into a Realized Gain
	Account	Transfer to	Transaction Amount	Account Total
	Income:Unrealized Gains	Income:Realized Gains	$50,000	$-20,000
	Assets:Fixed Assets:Degas:Cost	Assets:Current Assets:Savings Account	$100,000	$0
	Assets:Fixed Assets:Degas:Unrealized Gains	Assets:Current Assets:Savings Account	$50,000	$-20,000
	Income:Unrealized Gains	Assets:Fixed Assets:Degas:Unrealized Gains	$20,000	$0





This leaves the Assets:Current Assets:Savings Account account
          with a total of $150,000 and Income:Realized Gains with a total of
          $50,000.





Putting It All Together



Now that we have covered the basic ideas behind the various
    transactions you must make to successfully track your credit card in
    GnuCash, let’s go through an example. In this example, we will make credit
    card purchases, refund two of the purchases, get charged interest on
    the unpaid balance, reconcile the credit card account, and finally make a
    partial payoff of the credit card.
Open GnuCash file



Start with opening the previous datafile we stored,
      gcashdata_5, and store it as
      gcashdata_6 directly. The main window should look
      something like this: 
[image: Starting account structure]Starting account structure for tracking a credit card in the
          putting it all together example.




Purchases



Let’s make some purchases on our visa card. Start by buying $25
      worth of food from the Greasy Spoon Cafe, $100 worth of clothing from
      Faux Pas Fashions, $25 worth of gasoline from Premium Gasoline, $125
      worth of groceries and household items from Groceries R Us (split
      between $85 in groceries and $40 in household items) and finally, $60
      worth of household items from CheapMart.
We also redo the exercise in previous chapter, with purchasing
      a pair of Jeans for $74.99 on April 3, and refund them two days later.
The register window for the credit card liability should look like this:
[image: Initial credit card purchases]Initial credit card purchases.




Refund



Now suppose that on April 15th you return the clothes you bought
      on April 11th from Faux Pas Fashions and they give you credit back on
      your credit card. Enter a transaction for the credit card refund for the
      full $100 amount. Remember to use the same transfer account you used for
      the original purchase, and enter the amount under the Payment column.
      GnuCash will automatically complete the name and transfer account for
      you, but it will also automatically enter the $100 in the Charge column.
      You will need to reenter the amount in the Payment column. The
      transaction looks like this:
[image: Item return transaction]Returning clothes to Faux Pas Fashions, refund to credit
            card.




Interest Charge



After the month of spending, unfortunately, the credit card bill
      arrives in the mail or you access it on-line through the internet. You
      have been charged $20 in interest on the last day of April because of
      the balance you carried from the previous month. This gets entered into
      the credit card account as an expense.
[image: Interest charge]Interest charge.




Reconciliation



When your credit card bill arrives you should reconcile your
      credit card account to this document. This is done using GnuCash’s
      built-in reconciliation application. Highlight the credit card account
      and click on Actions → Reconcile.... This reconciliation procedure is
      described in detail in the the section called “Reconciliation”,
      but we will step
      through the process here as well. For this example, let’s assume that
      the credit card statement is dated May 1st, with a final balance of
      $455. Enter these values in to the initial Reconcile window as shown
      here.
[image: Initial reconcile window]Initial account reconciliation window.



During the reconciliation process, you check off each transaction
      in the account as you confirm that the transaction appears in both your
      GnuCash account and the credit card statement. For this example, as
      shown in the figure below, there is a $300 difference between your
      GnuCash accounts and the credit card statement.
[image: Main reconcile window]Main account reconciliation window, demonstrating a
            discrepancy of $300.



Some investigation uncovers that you forgot to record a payment
      you made on March 5th to the credit card company for $300, you
      must enter this payment transaction from your bank account to the credit
      card. Now the credit card statement and your GnuCash account can be
      reconciled, with a balance of $455.

Payment



Assuming you have completed reconciliation of your credit card
      account, you need to make a payment to the credit card company. In this
      example, we owe $455 but will make a partial payment of $300 again this
      month. To do so, enter a transaction from your bank account to the
      credit card account for $300, which should reduce your credit card
      balance to $155. Your credit card account register should now appear
      like this:
[image: Reconciliation and payment]Account register after account reconciliation and
            payment.



Go back to the main window and save your file
      (gcashdata_6). Your chart of accounts is steadily
      growing, and it should now look like this:
[image: GnuCash main window]GnuCash Chart of Accounts after account reconciliation and
            payment.




Save file



Last, save the GnuCash data file (gcashdata_6).

Reports



As we did in the previous chapters, let’s have a look at a
        Cash Flow, and a Transaction Report.
      
	First let’s have a look at the Cash Flow report
          for the liability account Visa during the month of March.
Select the cash flow report from Reports → Income & Expense → Cash Flow.
          
[image: Cash Flow report for the month of March]This image shows the Cash Flow report after
                Chapter 7, Credit Cards.




	Now let’s have a look at corresponding transaction report for the Visa
            account.
          
Select the transaction report from Reports → Transaction Report.
          
[image: Transaction Report for the Visa account during March/April]This image shows the Transaction Report for the Visa account
                  during March/April.
                




	Now let’s change the transaction report to only show the various
            Expenses accounts.
          
[image: Transaction Report for the Expenses accounts during April]This image shows the Transaction Report for the various Expense accounts
                  during April.
                








Putting It All Together



In the previous sections of this chapter the concepts and mechanics
    of working with transactions in GnuCash have been discussed. This section
    will expand upon the chart of accounts initially built in the previous
    chapter, by setting some opening balances, adding transactions and a
    scheduled transaction.
Open GnuCash file



Start with opening the previous datafile we stored,
      gcashdata_3emptyAccts, and store it as
      gcashdata_4 directly. The main window should look
      something like this:
[image: Starting point for Putting It All Together]This image shows the starting point for this
          section.




Opening Balances



As shown earlier with the Assets:Checking
      account, the starting balances in an account are typically assigned to a
      special account called Equity:Opening Balance. To
      start filling in this chart of account, begin by setting the starting
      balances for the accounts. Assume that there is $1000 in the savings
      account and $500 charged on the credit card.
	Open the Assets:Savings account register.
          Select View from the menu and check to make sure
          you are in Basic Ledger style. You will view your transactions in
          the other modes later, but for now let’s enter a basic transaction
          using the basic default style.

	From the Assets:Savings account register
          window, enter a basic 2 account transaction to set your starting
          balance to $1000, transferred from Equity:Opening Balance.
          Remember, basic transactions transfer money from
          a source account to a destination account. Record the transaction
          (press the Enter key, or click on 
          the Enter icon).

	From the Assets:Checking account register
          window, enter a basic 2 account transaction to set your starting
          balance to $1000, transferred from Equity:Opening Balance.

	From the Liabilities:Visa account
          register window, enter a basic 2 account transaction to set your
          starting balance to $500, transferred from Equity:Opening Balance.
          This is done by entering the $500 as a charge
          in the Visa account (or decrease in the Opening Balance account),
          since it is money you borrowed. Record the transaction (press the 
          Enter key, or click on 
          the Enter icon).



You should now have 3 accounts with opening balances set.
      Assets:Checking,
      Assets:Savings, and
      Liabilities:Visa.
[image: Chart accounts after setting opening balance]This image shows the opening
          balances.




Additional Transaction Examples



Now add some more transactions to simulate a month’s expenses.
      During the month, $78 is spent on electricity, $45 on phone, and $350 on
      rent. All paid by check. We also spent $45.21 on groceries, received $670
      as salary, and paid our Internet bill this month. Finally, let’s move
      $100 from the savings account to the checking account.
	Open the Expenses:Electricity account
          register and enter a simple 2 account transaction to pay the $78
          electrical bill at the end of the current month (eg: March 28,
          2006). Enter a description (eg: Light Company) and the check number
          (eg: 102). The Transfer account should be
          Assets:Checking.

	Open the Assets:Checking account register
          and enter a simple 2 account transaction to pay the $45 phone bill
          at the end of the current month (eg: March 28, 2006). Enter a
          description (eg: Phone Company Name) and the check number (eg: 103).
          The Transfer account should be
          Expenses:Phone. Notice that you can enter
          expense transactions from either the credit side (the expense
          accounts) or the debit side (the asset account).

	Open the Expenses:Rent account register
          and enter a simple 2 account transaction to pay the $350 in rent at
          the end of the current month (eg: March 28, 2006). Enter a
          description (eg: April Rent) and the check number (eg: 104). The
          Transfer account should be
          Assets:Checking.

	Duplicate this transaction using the
          Duplicate button in the Toolbar. Start by
          clicking on the current rent transaction, and click on the
          Duplicate icon. Enter the transaction date a
          month out in the future (eg: April 28, 2006), and notice the blue
          line separator that GnuCash uses to separate future transactions
          from current ones. In this way, you can enter transactions before
          they occur.
You could also set up a scheduled transaction to pay your
          rent, since the value of the rent is likely to be constant for the
          foreseeable future. 
	Start by clicking on the current (April 28) rent
                transaction, and click on the Schedule
                icon

	Change to Monthly, change
                description if needed and press OK




	To transfer money from your savings account to your checking
          account, open the Assets:Savings account
          register, add a new transaction setting
          the Transfer to Assets:Checking in the amount
          of $100 (date 6 March, 2006).

	As another example of a simple 2 account transaction, add
          another transaction to describe the purchase of $45.21 worth of
          groceries on 5 of March. From within the Assets:Checking account, you
          would set Transfer to
          Expenses:Groceries. The account register should
          now appear:

	To add a paycheck transaction from the
          Assets:Checking account register window, click
          on a new transaction line, and click on Split.
          First enter the description of this transaction on the first line
          (eg: “Employers R Us”), as well as the date (14 March). In the
          “split” line below this, enter the deposit into
          Assets:Checking (eg:$670). Follow this with the various tax deposits
          (Assets:Checking (eg: $670),
          Expenses:Taxes:Federal account (eg: $180),
          Expenses:Taxes:Medicare account (eg: $90), and
          Expenses:Taxes:Social Security account (eg: $60)) and
          lastly the gross total of your paycheck (eg: $1000) as a withdrawal
          transfer from Income:Salary.

	You also need to pay for your Internet subscription of 20 USD on
          the 28th.



[image: Chart accounts after setting all the various transactions]This image shows the ending balances after Chapter 4, Transactions.




Save file



Before we go to the report section, let’s save the GnuCash data
      file (gcashdata_4).

Reports



But only having data available on the computer screen will not
      make your accountant happy, therefore GnuCash comes with a large number
      of highly customizable reports.
Let’s have a look at a Cash Flow, and a
      Transaction Report.
	First let’s have a look at the Cash Flow
          report for the month of March.
Select the cash flow report from Reports → Income & Expense → Cash Flow.
[image: Cash Flow report for the month of March]This image shows the Cash Flow report after Chapter 4, Transactions.



To get this customized report, right click in the report and
          choose Report Options. Then set the time
          period, and specify which accounts you want in the report.

	Now let’s have a look at corresponding transaction report for
          the Checking account.
Select the transaction report from Reports → Transaction Report.
[image: Transaction Report for the Checking account during March]This image shows the Transaction Report for the
              Checking account during March. 




	Now let’s change the transaction report to only show the
          various Expenses accounts.
[image: Transaction Report for the Expenses accounts during March]This image shows the Transaction Report for the
              various Expense accounts during March. 








Chapter 6. Expense Accounts



If managing your checkbook is the first step in tracking your finances, then using expense accounts
  to see where you are expending money is a close second step. This chapter will give you an understanding of
  how GnuCash uses expense accounts to help you keep track of many different
  categories of transactions.
Concepts



An expense type account is used to allow you to track how much you spend on specific
    expenses. Technically, expense accounts are not a part of traditional accounting,
    but have become common with the increased capabilities of computer-based accounting systems.
    Many people's first experience with tracking expenses comes from Quicken(tm), where
    transactions can be assigned to one or more categories. In GnuCash, these categories
    are set up as separate accounts, which are designated as Expense type accounts.
    This allows GnuCash to apply the rules of double-entry accounting consistently.
    Expense accounts can be as detailed or as general as you need. Some users need only a few accounts for
    personal expense tracking. Others use GnuCash expense accounts to manage their expenses
    in great detail. The level of detail you choose is up to you. Keep in mind that with GnuCash,
    you can change accounts for transactions, so if your needs change later on, it is possible to move
    transactions around.


Chapter 1. Overview



Introduction



GnuCash is the personal finance software package made for you. It is
    versatile enough to keep track of all your financial information, from the
    simple to the very complex. It is one of the few financial software
    packages that supports global currencies, and it is the only open-source
    program of its kind. Best of all, GnuCash is easy to learn and use!
So, what can GnuCash do for you? It can keep track of your personal
    finances in as much detail as you prefer. If you are just starting out,
    use GnuCash to keep track of your checkbook. You may then decide to track
    cash as well as credit card purchases to better determine where your money
    is being spent. When you start investing, you can use GnuCash to help
    monitor your portfolio. Buying a vehicle or a home? GnuCash will help you
    plan the investment and track loan payments. If your financial records
    span the globe, GnuCash provides all the multiple-currency support you
    need.
[image: GnuCash Chart of Accounts - Teaser]This image shows a Chart of Accounts with multiple currencies and investments.



While GnuCash is well suited for personal finances, it is also
    powerful enough for business use. There are many business features, from
    integrated accounts receivable and payable systems, to tax table
    construction. You will find these and the many other business features
    surprisingly powerful and easy to use.


Accounting



Q: How do I treat taxes?  As an account payable or as an expense?



A: This is a loaded question, and you should really talk to your accountant.  How you treat taxes really depends on what kind of taxes they are, and how you WANT to treat them..  In some cases they are expenses, in some cases they are liabilities.


Chapter 17. Python Bindings




    GnuCash historically has always been a
    traditional application in the sense that you open it, use it to
    manipulate your financial data via the windows it presents, save your
    data and close the windows again. This has the inherent limitation that
    you can only do whatever the windows, menus and toolbars allow you to do.
  

    Sometimes you might need a little more flexibility. For example, you
    need a report with just a little different information than what the
    built-in reports provide, or you want to automate a frequently recurring
    action. Such custom manipulations are ideal candidates to write in one
    or the other scripting language.
  

    Starting with GnuCash version 2.4 you can
    write Python scripts to manipulate your financial data.
  
Note
The Python extensions are an optional feature in the source code.
      To be able to use Python scripts, GnuCash must
      have been compiled with this option enabled, otherwise all what follows
      won’t work. At present this option is not enabled by default, so if you
      need this, you may have to compile GnuCash from
      source yourself.
    

The Python extensions come with a couple of ready to use scripts. This
    chapter will show you how to use some of these.
  
Note
This chapter is not about how to write your own Python scripts.
      Refer to the developer documentation for that instead.
    


Taxation



Taxation policies vary considerably between countries, so it is
    virtually impossible to say anything that will be universally useful.
    However, it is common for income generated by capital gains to not be
    subject to taxation until the date that the asset is actually sold, and
    sometimes not even then. North American home owners usually find that when
    they sell personal residences, capital gains that occur are exempt from
    taxation. It appears that other countries treat sale of homes differently,
    taxing people on such gains. German authorities, for example, tax those
    gains only if you owned the property for less than ten years.
Chris Browne has a story from his professional tax preparation days
    where a family sold a farm, and expected a considerable tax bill that
    turned out to be virtually nil due to having owned the property before
    1971 (wherein lies a critical “Valuation Day” date in Canada) and due to
    it being a dairy farm, with some really peculiar resulting deductions. The
    point of this story is that while the presentation here is fairly simple,
    taxation often gets terribly complicated...

2. VERBATIM COPYING




      You may copy and distribute the Document in any medium, either
      commercially or noncommercially, provided that this License, the
      copyright notices, and the license notice saying this License
      applies to the Document are reproduced in all copies, and that
      you add no other conditions whatsoever to those of this
      License. You may not use technical measures to obstruct or
      control the reading or further copying of the copies you make or
      distribute. However, you may accept compensation in exchange for
      copies. If you distribute a large enough number of copies you
      must also follow the conditions in section 3.
    

      You may also lend copies, under the same conditions stated
      above, and you may publicly display copies.
    

Reconciling Statements in a Foreign Currency (How-To)



Reconciling foreign statement are done in the same manner as when
    you reconcile your local bank statement. If you have created a Chart of
    Accounts structure which allows you to have the same Currency per account
    as your Reconcile Statement, it is actually exactly the same as
    reconciling your local bank statement, apart from the fact you might need
    a dictionary
If you have different currencies you might have to manually convert
    the amounts from one currency to another while you reconcile the
    accounts.

Appendix E. GNU Free Documentation License


      Version 1.1, March 2000
    

Copyright © 2000 Free Software Foundation, Inc.


	
Free Software Foundation, Inc. 59 Temple Place,

        Suite 330, Boston, MA

        02111-1307  USA


	Everyone is permitted to copy and distribute verbatim copies of this
        license document, but changing it is not allowed.
      




0. PREAMBLE




      The purpose of this License is to make a manual, textbook, or
      other written document “free” in the sense of
      freedom: to assure everyone the effective freedom to copy and
      redistribute it, with or without modifying it, either
      commercially or noncommercially. Secondarily, this License
      preserves for the author and publisher a way to get credit for
      their work, while not being considered responsible for
      modifications made by others.
    

      This License is a kind of “copyleft”, which means
      that derivative works of the document must themselves be free in
      the same sense. It complements the GNU General Public License,
      which is a copyleft license designed for free software.
    

      We have designed this License in order to use it for manuals for
      free software, because free software needs free documentation: a
      free program should come with manuals providing the same
      freedoms that the software does. But this License is not limited
      to software manuals; it can be used for any textual work,
      regardless of subject matter or whether it is published as a
      printed book. We recommend this License principally for works
      whose purpose is instruction or reference.
    


Reconciling with the Loan Statements (How-To)



Reconciling a loan statement is no different from reconciling a bank
    or credit card statement.
During the period you should have recorded all the various loan
    related transactions, and every one of them are touching the
    Liability:Loans:Loan account. For instance,
    paying off a bit of the loan decreases your Bank
    Account, and increases the Loan account,
    Loan Interest as well as perhaps Loan
    administration fee.
With the loan statement in your hands, open the Loan account, start
    the reconcile assistant, and tick of all the various transaction you have
    recorded. When you have finished, the reconciling difference should be 0,
    and if it is not, then you will have to go through the account and compare
    it with the loan statement to find the difference. When you have reached a
    0 in difference, then your loan account is reconciled and you can finish
    the Reconcile assistant.
For more information on how to Reconcile, please check the section called “Reconciliation”

Accounts Receivable



Accounts Receivable (or A/R) refers to products or services provided
       by your company for which payment has not yet been received.
System Components



Transactions generated by the A/R system are recorded within the Accounts
                Receivable account. You should not work directly with this account.
                Instead, you will work with the four integrated GnuCash A/R application
                components available through the Business → Customer sub-menu. These four components are:
	Customers are people or companies to whom
                        you sell products or services on credit.

	Invoices represent the physical invoice you
                        send to a customer to request payment. This invoice contains an
                        itemized list of things you sold.
In addition, GnuCash also has support for Credit Notes
                        which represent the inverse of Invoices. A credit note is usually handed to
                        a customer to correct items that were incorrectly invoiced or returned.
Both document types will be set up using the same menu items. Credit notes were introduced starting with
                        GnuCash stable release 2.6.0.
                    

	Jobs (optional) is where you register
                        Customer Jobs. Jobs are a mechanism by which you can group multiple
                        invoices to a particular customer.

	Process Payments is used to register
                        payments you received from a customer.




Customers



Customers are people or companies to whom you sell goods or
                services. They must be registered within the A/R system.
New



To register a new customer, enter the menu Business → Customer → New Customer. Fill in customer information, such as
                Company Name, Address, Phone, Fax, etc.
Figure 13.6. New Customer Registration Window
[image: New Customer Registration Window]





Find and Edit



To search for an existing customer, use the Business → Customer → Find Customer window. You select a customer to
                View/Edit from the results of the search. This
                window is also used to look up customers when creating invoices and
                    processing payments.
Figure 13.7. Find Customer Window
[image: Find Customer Window]




If many customers match the search criteria you provide, the
                    search can be refined by running an additional search within the current
                    results. The current result set is searched when the Refine
                        Current Search radio button is selected. In fact, GnuCash
                    selects this option for you after you run the initial search.
If the customer you are searching for does not match the supplied
                    search criteria, change the search criteria, click the New
                        Search radio button and then the Find
                    button. The relevant step is the New Search
                    selection. If the customer is not in the result of the original search,
                    and you only search within this set, the customer cannot be found,
                    regardless of new search criteria.
Note
To return a list of all registered active customers, set the
                        search criterion to matches regex, and place a
                        single dot "." in the text field area. Make sure Search only
                            active data is checked, then click
                        Find. The regular expression "." means to match
                        anything.



Invoices



An invoice is the paperwork you send to a customer to request
                payment for products or services rendered. GnuCash can generate and track
                invoices.
A credit note is the paperwork you send to a customer to correct
                products or services rendered that were incorrectly invoiced. GnuCash can generate and track
                credit notes via the same menu entries as invoices.
Note
This section applies to both invoices and
                    credit notes. In order to avoid repeating everything twice and to keep
                    the text easier to read it will refer only to invoices. You can apply
                    it equally to credit notes. Only where the behavior of credit notes
                    differs from invoices this will be explicitly mentioned.

New



To send an invoice to a customer you must first create the new
                    document. To create an invoice use Business → Customer → New Invoice. The
                    New Invoice window must be filled in appropriately.
Figure 13.8. Creating a New Invoice
[image: Creating a New Invoice]




When you click the OK button, the
                    Edit Invoice window opens.

Edit



From the Edit Invoice window you can enter an itemized list of
                    goods and services you sold on this invoice in a manner similar to how the account
                    register works. For credit notes you enter an itemized list of goods and
                    services you refunded instead.
Figure 13.9. Edit Invoice Window
[image: Edit Invoice Window]




When you have finished entering all the items, you can
                    Post and print the invoice.

Post



When you finish editing an invoice and are ready to print, you
                    must Post the invoice. The invoice does not have to
                    be posted immediately. In fact, you should only post an invoice when you
                    are ready to print it. Posting an invoice places the transactions in an
                    accounts receivable account.
Figure 13.10. Post Invoice Window
[image: Post Invoice Window]





Find



To find an existing invoice, use the Business → Customer → Find Invoice
                menu item. From the results of the search, you can select an invoice
                    to edit or view.
Note
Before you can edit a posted invoice, you will need to
                        Unpost it.

One of the design goals in GnuCash’s Account Receivable system was
                    to allow different processes to get to the same state, so you can reach
                    an invoice from different directions based on the way you think about
                    the problem:
	You can search for the customer first, then list their
                            invoices.

	You can search for invoices by number or by company
                            name.

	You can list invoices associated with a customer job.




Print



After you post an invoice, you should print it and send it to your
                    customer. To print an invoice use File → Print Invoice menu item.
Figure 13.11. Invoice Print Output
[image: Invoice Print Output]




Note
You can modify the appearance of the invoice, IE: add a company
                        logo, etc. To do so, see the the section called “Changing the Invoice Appearance”.

Invoices can also be printed from the main window by selecting
                    Reports → Business Reports → Printable Invoice from the main menu. The
                    resulting report window states that no valid invoice is selected. To
                    select the invoice to print:
	Use the Options Toolbar button or select
                            Edit → Report Options from
                            the main menu.

	Select the General tab of the report
                            options dialog.

	Click the Select button next to the
                            Invoice Number field.

	Search for the invoice as usual.



You can also print invoices from within the Process Payment
                    dialog. See the the section called “Process Payment” for instructions on
                    how to do so.

Assign Starting Invoice Number



By default, GnuCash starts with invoice number 1 and increments from there. You can
                    manually type an invoice number into the text box each time you create
                    an invoice, but this gets tiring and sooner or later leads to duplicate
                    numbers.
You can change the starting invoice number if it is important you.
                    Use File → Properties, access
                    the Counters tab, change the Invoice number value to be
                    one less than your desired starting invoice number and click the OK button or the
                    Apply button.


Customer Jobs



Customer Jobs are used to group multiple invoices and credit notes to the same
                customer. Use of the Customer Jobs feature is optional. The feature is
                useful when you have multiple jobs for the same customer, and would like
                to view all the invoices and credit notes related to a single job.
Figure 13.12. New Customer Job
[image: New Customer Job]




To use customer jobs, you must create them using the Business → Customer → New Job menu item. You will see the New
                    Job window.
To edit an existing customer job, use the Business → Customer → Find Job menu item. Select the desired job in the
            search results, and click the View/Edit Job
                button.
To select from the invoices and credit notes associated with a given job, use Business → Customer → Find
                    Job menu item. Select the desired job in the
            search results and click the View Invoices button. A
            window listing invoices and credit notes associated with this job appears. Select an
            invoice or credit note and click the View Invoice button to open an
                invoice editor in the main application window.

Process Payment



Eventually, you will receive payment from your customers for
                outstanding invoices. To register these payments, use the Process Payment
                application found in Business → Customer → Process
                        Payment.
Figure 13.13. Process Customer Payment
[image: Process Payment from Customer]Process Payment from Customer







Changing the Invoice Appearance



The default Invoice style, as shown in the section called “Print”, is fairly barren. The default invoice
                style leaves the top part of the form blank, so you can print on company
                letterhead paper. There are some things you can do to change invoice
                appearance.
Use File → Properties to
                enter your Company information in the Business tab of the Book Options window.
                Some of the entered information is printed on the right side of invoices.
To add a customized background, heading banner or logo to invoices,
                modify the invoice style sheets. To do this, go to Edit → Style Sheets and select the New
                button in the Select HTML Style Sheet window that will appear.
                You will then see a window like this:
Figure 13.14. The New Style Sheet Window
[image: New Style Sheet Window]




Give a Name to the new style sheet (e.g. Custom Invoice) and select the
                Fancy Template. When you click the
                OK button, the HTML Style Sheet Properties window is
                displayed. This window presents you five sections listed in the left pane: Colors, Fonts,
                General, Images, and Tables. The Colors
                section allows you to change the colors of various items of the invoice. The Fonts section lets you
                set fonts type and dimensions. The General section allows you to set the Preparer and
                Prepared for information, and to Enable Links. The Images section allows you
                to import graphics into the style sheet. The Tables section allows you to
                adjust the spacing around the tables which make up the invoice.
To include a company logo, banner heading and background image, use
                your favorite graphics application such as The Gimp or OpenOffice Draw to
                save the images in either GIF or PNG format. Then import them into the
                style sheet using the Images section described above.
Below is an example that imports all three types of images.
Figure 13.15. HTML Style Sheets Example Window
[image: HTML Style Sheets Example Window]The HTML Style Sheets window with an example Background
                        Tile, Heading Banner, and Logo.






Note
The images are placed in the invoice as follows. The
                    Background Tile is tiled to become the background
                    image, the Heading Banner goes to above the invoice
                    text, and the Logo is placed in the upper left corner
                    of the invoice to the left of the Heading Banner. You will probably have
                    to try a few different sized images until you get the invoices to print
                    nicely. Some sizing suggestions are that the Logo should be 1 square cm
                    (~0.5 inch), and the Heading Banner should be 15 cm (~6 inches) wide and 1
                    cm (~0.5 inch) tall.

With the style sheet configured, when you print the invoice, you
                select the style sheet to use from the Options menu.
                Below is the resultant invoice after applying the style sheet demonstrated
                above.
Figure 13.16. HTML Style Sheets Example Output
[image: HTML Style Sheets Example Output]The hideous invoice which results from the graphics
                        selected in the style sheet.








Organization of QIF Files (Discussion)




  

Appendix B. Frequently Asked Questions



This is a list of questions asked on the mailing lists for which there really is no section in the documentation covering the subject.
Sources of Information



Q: Where’s the FAQ?



A: You’re looking at it. The most up-to-date copy can be found within the GnuCash Wiki.

Q: Are there mailing lists for GnuCash?



A: Yes. Go to http://lists.gnucash.org/mailman/listinfo/gnucash-user and http://lists.gnucash.org/mailman/listinfo/gnucash-devel to subscibe.

Q: Is there a searchable archive for the mailing lists?



A: Yes, you can search the mail list archives at http://news.gmane.org/gmane.comp.gnome.apps.gnucash.devel and http://news.gmane.org/gmane.comp.gnome.apps.gnucash.user (and http://news.gmane.org/gmane.comp.gnome.apps.gnucash.german if you speak German).

Q: Are there other means of obtaining support for GnuCash?



A: Yes. Many of the developers hang out on icq in the #gnucash discussion on irc.gnome.org. Also, there is a wiki online at http://wiki.gnucash.org/wiki/GnuCash.



Scheduled Transactions



Scheduled transactions are made to help entering repetitive money
    operations, like subscriptions, insurances or taxes. By using scheduled
    transactions, you only have to enter the concerned transaction once, set a
    few parameters like start date, frequency and a little description, and
    then GnuCash will tell you whenever a scheduled transaction is ready to be
    created, and create it for you.
In this howto, we’ll take a monthly Internet subscription of 20 USD
    as example, which is taken on the 28th of each month.
In GnuCash, there are two ways of creating scheduled transactions,
    from the ledger or from the
    Scheduled Transactions Editor.
Creating from the Ledger



Enter the first occurrence of your to-schedule transaction in the
      ledger. In the Transfer field for this transaction, type
      Expenses:Internet as shown in the next screenshot.
[image: Step one creating scheduled transaction from the ledger]Step one creating scheduled transaction from the
          ledger



Note
Since we did not create the Expenses:Internet account, GnuCash
        will prompt us to create it.

Then you right click on your transaction and select
      Schedule...
[image: Step two creating scheduled transaction from the ledger]Step two creating scheduled transaction from the
          ledger



A window like this will appear:
[image: Step three creating scheduled transaction from the ledger]Step three creating scheduled transaction from the
          ledger



Let’s fill the values, we know that the subscription is taken on
      the 28th each month, and the next one is for next month (since we
      entered the one for this month manually) :
[image: Filling in data to a scheduled transaction]Filling in data to a scheduled
          transaction



Click the OK button, and the transaction will be scheduled.
      GnuCash now has memorized this scheduled transaction and on the 28th of
      next month, it will pop up a window asking if it should create it (see
      far below for a screenshot of this window).

Creating from the Editor



Another way of entering a scheduled transaction is from the
      Scheduled Transaction Editor, it may be faster if we have several
      scheduled transactions to create at once.
From the main accounts windows, select
      Actions → Scheduled Transactions → Scheduled Transaction Editor from the Menubar.
      A new Scheduled Transactions tab will be opened in the
      current GnuCash window as shown above:
[image: Empty Scheduled Transactions tab]Empty Scheduled Transactions tab



This tab contains a list, now empty, of all the scheduled
      transactions. Let’s create a new one by clicking on the New
      button in the Toolbar. A window like the one below will pop up:
[image: Edit Scheduled Transaction window, Overview tab]Edit Scheduled Transaction
           window, Overview tab



First, let’s enter a name for this new scheduled
      transaction in the top of the window.
Note
This name will only identify the transaction
        in the Edit Scheduled Transaction window,
        it will never appear in the ledger.

In the Options pane of the Overview
      tab you have four options:
	Enable
	Sets the status of the scheduled transaction.

	Create automatically
	If enabled, will insert this transaction in the
            ledger without asking you before (see below). If needed, you can be advised
            when the transaction is entered by checking the Notify me when created
            option.

	Create in advance
	Sets how many days in advance the transaction will be created.

	Remind in advance
	Sets how many days in advance a reminder is presented. This
            can be used, for example, when you have to pay something by check, and a reminder
            one week before allows you to send your check before the deadline.



The Occurences pane allows you to tell GnuCash that
      this scheduled transaction won’t last for ever. For example if you are repaying a loan,
      you can enter the loan end date or the number of occurences left.
Select now the Frequency tab in the Edit Scheduled Transaction window.
      Here you can set the time-related options of the transaction.
[image: Edit Scheduled Transaction window, Frequency tab]Edit Scheduled Transaction
            window, Frequency tab



	Frequency
	Sets the basic frequency of the transaction, with options for once,
            daily, weekly, semi-monthly and
            monthly.
            In this example, this is set to monthly.
Note
It is possible to set a transaction to occur at intervals other than
              those listed in the Frequency list, by changing the setting in the
              Every control (see below).


	Start Date
	Sets when the transaction will begin. In the example, this would
            be set to the start of the next month.

	Every
	This option allows you to schedule transactions by multiplies of the value in
            Frequency. For example, to create a transaction that runs every 3 weeks, set
            Frequency to Weeks and Every to
            3.

	On the and Except on weekends
	Sets the day of the month that the transaction is scheduled, and controls what
            GnuCash will do when the day occurs on a weekend day.



Note
We know that the subscription is taken on the 28th each month, so the Start date
        will be November 1, 2003 (assuming November is the next month), the Frequency will be
        Monthly, it will be taken every month on the 28th. Since in our example the internet
        subscription is automatically taken from the account, we have no need to create it in advance, nor
        give an end date.

When the elements on this tab are filled in, GnuCash will highlights the
      calendar below to indicate when future transactions will be run.
Finally select the Template Transaction tab and enter your transaction
      in the lower part as you would do in the ledger, with the only difference of having no date.
Now, you should have a window like this:
[image: Edit Scheduled Transaction window, Template Transaction tab]Edit Scheduled Transaction
            window, Template Transaction tab



Remember to click on the Enter icon, to validate and enter the
      transaction.
Now click OK, it takes you to the Scheduled Transactions tab,
      now showing one item in the Transactions list:
[image: Entered scehduled transaction]Entered scehduled transaction



Tip
If you click in the calendar part on the first day of one month, a
        small window, following your mouse, will show you what is planned for
        this day. To make the small window dissapear again, just click in it
        one more time.

You can now close the Scheduled Transaction tab, and
      save your work.
Note
What comes below is just an illustration, and is not meant to be
        entered into the GnuCash database at this stage. As per this example,
        the below dialogs will appear when the scheduled transaction is
        supposed to run.

From now on, when GnuCash is launched and a scheduled
      transaction is scheduled or need to be entered,
      you may see a Since Last Run... window summarizing the scheduled transactions
      operations (Reminder, To-Create etc... a better
      description of each option can be found in the GnuCash manual):
[image: Scheduled transaction popup reminder]Scheduled transaction popup reminder



You can click on the Status column to change
      the scheduled transaction status if needed. Then just click on Ok to
      close the Since Last Run... window and to apply the pending operations.
      Select Cancel to skip entering in the ledger the pending operations.
If the Status field was set to To-Create,
      then if you take a look in your bank account register, you’ll see the transaction has been created:
Tip
If you enable the Review created transactions option in the lower right of the
        Since Last Run... window, GnuCash will open, after pressing
        Ok, the register tab of each account where the scheduled
        transactions were entered automatically.

Note
If you entered the transaction for 28 of April at this stage,
        then please revert back to the last saved GnuCash file
        by selecting File → Open and
        choosing the previously saved gcashdata_3 GnuCash file.



