
  
    
  
3. COPYING IN QUANTITY




      If you publish printed copies of the Document numbering more than 100,
      and the Document’s license notice requires Cover Texts, you must enclose
      the copies in covers that carry, clearly and legibly, all these
      Cover Texts: Front-Cover Texts on the front cover, and
      Back-Cover Texts on the back cover. Both covers must also
      clearly and legibly identify you as the publisher of these
      copies. The front cover must present the full title with all
      words of the title equally prominent and visible. You may add
      other material on the covers in addition. Copying with changes
      limited to the covers, as long as they preserve the title of the
      Document and satisfy these
      conditions, can be treated as verbatim copying in other
      respects.
    

      If the required texts for either cover are too voluminous to fit
      legibly, you should put the first ones listed (as many as fit
      reasonably) on the actual cover, and continue the rest onto
      adjacent pages.
    

      If you publish or distribute Opaque copies of the Document numbering more than 100,
      you must either include a machine-readable Transparent copy along with
      each Opaque copy, or state in or with each Opaque copy a
      publicly-accessible computer-network location containing a
      complete Transparent copy of the Document, free of added
      material, which the general network-using public has access to
      download anonymously at no charge using public-standard network
      protocols. If you use the latter option, you must take
      reasonably prudent steps, when you begin distribution of Opaque
      copies in quantity, to ensure that this Transparent copy will
      remain thus accessible at the stated location until at least one
      year after the last time you distribute an Opaque copy (directly
      or through your agents or retailers) of that edition to the
      public.
    

      It is requested, but not required, that you contact the authors
      of the Document well before
      redistributing any large number of copies, to give them a chance
      to provide you with an updated version of the Document.
    

Chapter 8. Reports And Charts



Note
This section is a “work in process” all of the material has not been reviewed for V2.0.
      While it may not be strictly accurate, it is at least a "guide".

Reports and Charts give GnuCash the ability to present an overview of financial
    data in various ways. This can range from a simple summary of account totals to an
    advanced portfolio view. This section will present an explanation of the main GnuCash
    reports and how to adjust them.
GnuCash has classified the main types of reports into four major classes. These
    are all available under the Reports menu.
General Reports



The General Reports include the Account Summary Report, Custom Reports, the Tax Schedule Report and TXF Export, and the Transaction Report and also the reports in the Sample & Custom menu.
	Account Summary:

	Tax Schedule Report and TXF Export: The tax schedule report lists all taxable income and deductible expense amounts used in the preparation of US Income Tax returns. The purpose of the report is to provide a complete audit trail for these amounts. The report is intended to be used by a tax payer to manually prepare his or her own tax return, or alternatively, to be provided to a tax preparer for that purpose. The report can also be used to generate an export of all tax related income and expenses to a TXF (Tax eXchange Format) file (this is in addition to exporting to the HTML format that all reports allow). The TXF file can be imported into tax filing programs such as TaxCut or TurboTax. The report should be run, inspected carefully for errors or omissions, and then corrections made to transactions, report settings, currency conversion rates or the account structure as needed. This process should be repeated as often as needed until all the amounts on the report are correct before a final version is used and saved along with the tax returns.
 For accounts specified in the report options (none = all) that are also flagged as Tax-related, all transactions for the time period selected (also in the report options) are included. The report sorts transactions by date within account providing subtotals by account within tax code within Form or Schedule line number. Support is also provided for multiple copies of and for sub-line items for selected Forms/Schedules. Optionally uses special date processing to include federal estimated tax payments after year end.
All totals are in USD since this is the currency required for filing US Income Tax returns. Non-USD transaction amounts are converted to USD using the transaction conversion rate to USD, if available. If not, a conversion rate from the price database is used (either the date nearest the transaction date or nearest the report date as specified in the report options; if none is available, transaction amounts are converted to zero and the report provides a comment accordingly). A complete audit trail of conversions is provided.
Note
For this to work, the user has to segregate taxable and non taxable
           income to different accounts, as well as deductible and non deductible expenses.
           The Income Tax Information dialog is used for this. To access the Income Tax
           Information dialog go to Edit → Tax Report Options. The user
           also must set the TXF category of each tax related account. The Income Tax
           Information dialog is described in the the section called “Setting Tax Report Options” section.


	Transaction Report:

	Welcome Sample Report:

	Custom Multicolumn Report: This report is used to place multiple reports
           into a single report window to examine a set of financial information at a glance.

	Sample Graphs

	Sample Report with Examples:





Since Last Run Assistant



The Since Last Run assistant is run automatically when 
      GnuCash is started. It is
      used to enter into the register any transactions that are due to be automatically
      entered (see the section called “Scheduling Transactions”). The run on GnuCash start can be 
      altered in the Scheduled Transactions tab of the GnuCash Preferences.
      To run the Since Last Run assistant manually, go to 
      Actions → Scheduled Transactions → Since Last Run...
In the Since Last Run assistant window you can see three columns:
	Transaction
	The name assigned in the Scheduled Transaction Editor that identifies 
              the scheduled transaction.

	State
	The state column of the scheduled transaction can be one of the
              following:
Tip
Click on the state field in the row of a transaction to 
                change its state (this option is available only if the state field is not 
                empty)

	Ignored
	If a scheduled transaction is being displayed, either to be created or as a reminder, the user can
                      set the status to Ignored to skip this event. The scheduled transaction will not be entered in
                      the register and the next reminder for this scheduled transaction will be the next occurrence. 
                      For instance, if you have a scheduled transaction set up with a reminder to transfer $500 at the
                      end of the month to your savings account but you bought yourself a computer
                      this month and don’t have the money for this month’s transfer then you would
                      set the status to Ignored.

	Postponed
	If a scheduled transaction has been listed with a status To-create but you
                      want to hold it and not have it entered to your register yet, then you can set it 
                      to Postponed.

	Reminder
	You are n days from the scheduled transaction due date. 
                      The number of days n to remind in advance, is set either in 
                      the GnuCash Preferences Scheduled Transactions 
                      tab or in the Overview tab of the 
                      Scheduled Transaction Editor.

	To-create
	This scheduled transaction will be automatically created when 
                      you press OK.

	Empty
	An empty field means that no operations are pending for the 
                      scheduled transaction.






At the bottom of the window there are two buttons:
	The Cancel button is used to exit the Since Last Run
            window without creating the transactions scheduled to be entered.

	The Ok button closes the Since Last Run window and applies 
            the pending operations.



At the bottom right of the Since Last Run window there is also an 
        option that allows to Review created transactions. If this option 
        is enabled when there are one or more transactions To-create, 
        pressing OK will open a register window in which are shown the 
        details of the scheduled transactions splits entered automatically by GnuCash.

Changing Style Sheets



GnuCash has four default style sheets for web-page reports. These style sheets can
       be altered by using the HTML Style Sheets editor. To access the editor go to Edit → Style Sheets...
Using the Style Sheet Editor you may display/modify the setting of a Style
       Sheet.
Note
Changing the Style Sheet will change the appearance of all reports
       that have selected that Style Sheet. A Reload is required to view the changes, if
       the report(s) are currently displayed.

To add a new Style Sheet click the New... button in the Style Sheet pane.
       The New Style Sheet dialog will appear. Fill in the name field with 
       the name of the new Style Sheet and choose a template. To remove a Style Sheet select the Style Sheet from
       the list and click Delete.
Default Style Sheet



The Default Style Sheet has four tabs to alter the appearance of 
         reports utilizing it, Colors, Fonts, General and Tables. 
Colors Tab



	Alternate Table Cell Color: Opens the 
               color picker to choose a color that will be applied to alternate
               table rows.




Fonts Tab



	Title: Select the font and size for 
               Titles.

	Account Link: Select the font and size 
               for Account Links.

	Number Cell: Select the font and size 
               for Number Cells.

	Negative Values in Red: Select to have
               negative values displayed in red.

	Text Cell: Select the font and size 
               for Text Cells.

	Total Number Cell: Select the font and 
               size for Total Number Cells.

	Total Label Cell: Select the font and
               size for Total Label Cells.

	Centered Label Cell: Select the font and
               size for Centered Label Cells.




General Tab



	Background Color: Opens the color picker 
               to choose a new background color.

	Background Pixmap: Use the Browse button 
               to select a picture to use as the background in reports.

	Enable Links: Select this to enable 
               blue hyperlinks in reports.




Tables Tab



	Table cell spacing: Sets the space between table
               cells

	Table cell padding: Sets the space 
               between table cell edges and contents

	Table border width: Sets the width of 
               the borders on tables.





Easy Style Sheet



The Easy Style Sheet has five tabs to alter the appearance of 
         reports: Colors, Fonts, General, Images and Tables.
Colors



	Background Color: Opens the color picker 
               to choose a new background color.

	Text Color: Opens the color picker to 
               choose a new text color.

	Text Cell Color: Opens the color picker
               to choose a new text cell color.

	Link Color: Opens the color picker to 
               choose a new link color.

	Alternate Table Cell Color: Opens the 
               color picker to choose a new color for alternate table rows.

	Subheading/Subtotal Cell Color: Opens 
               the color picker to choose a new color for subheading/subtotal 
               table rows.

	Sub-subheading/total Cell Color: Opens 
               the color picker to choose a new color for sub-subheading/total 
               table rows.

	Grand Total Cell Color: Opens the color 
               picker to choose a new color for grand total rows.




Fonts



	Title: Select the font and size for 
               Titles.

	Account Link: Select the font and size 
               for Account Links.

	Number Cell: Select the font and size 
               for Number Cells.

	Negative Values in Red: Select to have
               negative values displayed in red.

	Number Header: Select the font and size 
               for Number Header table rows.

	Text Cell: Select the font and size 
               for Text Cells.

	Total Number Cell: Select the font and 
               size for Total Number Cells.

	Total Label Cell: Select the font and
               size for Total Label Cells.

	Centered Label Cell: Select the font and
               size for Centered Label Cells.




General



	Preparer: Name of the person preparing 
               the report.
              

	Prepared for: Name of Organization or Company the
               report is prepared for.

	Show preparer info: Show the Preparer information in
               the report.

	Enable Links: Select this to enable blue hyperlinks
               in reports.




Images



	Background Tile: Use the Browse button to select a
               picture to use as the background in reports. The Clear button will clear the
               selection.
              

	Heading Banner: Use the Browse button to select a
               picture to use as the heading in reports.  The Clear button will clear the
               selection.

	Heading Alignment: Select from pull-down list; Left,
               Right, Center, to specify the alignment of the banner at top of report(s).

	Logo: Use the Browse button to select a picture to
               use as the logo in reports.  The Clear button will clear the selection.




Tables



	Table cell spacing: Sets the space between table
               cells

	Table cell padding: Sets the space 
               between table cell edges and contents

	Table border width: Sets the width of the borders on
               tables.





Footer Style Sheet



The Footer Style Sheet has the same five tabs to alter the 
         appearance of reports as the Easy Style Sheets: Colors, Fonts, General, 
         Images and Tables.
Colors



	Background Color: Opens the color picker 
               to choose a new background color.

	Text Color: Opens the color picker to 
               choose a new text color.

	Text Cell Color: Opens the color picker
               to choose a new text cell color.

	Link Color: Opens the color picker to 
               choose a new link color.

	Alternate Table Cell Color: Opens the 
               color picker to choose a new color for alternate table rows.

	Subheading/Subtotal Cell Color: Opens 
               the color picker to choose a new color for subheading/subtotal 
               table rows.

	Sub-subheading/total Cell Color: Opens 
               the color picker to choose a new color for sub-subheading/total 
               table rows.

	Grand Total Cell Color: Opens the color 
               picker to choose a new color for grand total rows.




Fonts



	Title: Select the font and size for 
               Titles.

	Account Link: Select the font and size 
               for Account Links.

	Number Cell: Select the font and size 
               for Number Cells.

	Negative Values in Red: Select to have
               negative values displayed in red.

	Number Header: Select the font and size 
               for Number Header table rows.

	Text Cell: Select the font and size 
               for Text Cells.

	Total Number Cell: Select the font and 
               size for Total Number Cells.

	Total Label Cell: Select the font and
               size for Total Label Cells.

	Centered Label Cell: Select the font and
               size for Centered Label Cells.




General



	Preparer: Name of the person preparing 
               the report.
              

	Prepared for: Name of Organization or Company the
               report is prepared for.

	Show preparer info: Show the Preparer information in
               the report.

	Enable Links: Select this to enable blue hyperlinks
               in reports.

	Footer: Text to be included in report
               footer.




Images



	Background Tile: Use the Browse button to select a
               picture to use as the background in reports. The Clear button will clear the
               selection.
              

	Heading Banner: Use the Browse button to select a
               picture to use as the heading in reports.  The Clear button will clear the
               selection.

	Heading Alignment: Select from pull-down list; Left,
               Right, Center, to specify the alignment of the banner at top of report(s).

	Logo: Use the Browse button to select a picture to
               use as the logo in reports.  The Clear button will clear the selection.




Tables



	Table cell spacing: Sets the space between table
               cells

	Table cell padding: Sets the space 
               between table cell edges and contents

	Table border width: Sets the width of
               the borders on tables.





Technicolor Style Sheet



The Technicolor Style Sheet has has five tabs to alter the 
         appearance of reports: Colors, Fonts, General, Images and Tables.
Colors



	Background Color: Opens the color picker 
               to choose a new background color.

	Text Color: Opens the color picker to 
               choose a new text color.

	Text Cell Color: Opens the color picker
               to choose a new text cell color.

	Link Color: Opens the color picker to 
               choose a new link color.

	Alternate Table Cell Color: Opens the 
               color picker to choose a new color for alternate table rows.

	Subheading/Subtotal Cell Color: Opens 
               the color picker to choose a new color for subheading/subtotal 
               table rows.

	Sub-subheading/total Cell Color: Opens 
               the color picker to choose a new color for sub-subheading/total 
               table rows.

	Grand Total Cell Color: Opens the color 
               picker to choose a new color for grand total rows.




Fonts



	Title: Select the font and size for 
               Titles.

	Account Link: Select the font and size 
               for Account Links.

	Number Cell: Select the font and size 
               for Number Cells.

	Negative Values in Red: Select to have
               negative values displayed in red.

	Number Header: Select the font and size 
               for Number Header table rows.

	Text Cell: Select the font and size 
               for Text Cells.

	Total Number Cell: Select the font and 
               size for Total Number Cells.

	Total Label Cell: Select the font and
               size for Total Label Cells.

	Centered Label Cell: Select the font and
               size for Centered Label Cells.




General



	Preparer: Name of the person preparing the report.
              

	Prepared for: Name of Organization or Company the
               report is prepared for.
              

	Show preparer info: Show the Preparer information in
               the report.

	Enable Links: Select this to enable blue hyperlinks in
               reports.




Images



	Background Tile: Use the Browse button to select a
               picture to use as the background in reports.  The Clear button will clear the
               selection.

	Heading Banner: Use the Browse button to select a
               picture to use as the heading in reports.  The Clear button will clear the
               selection.

	Heading Alignment: Select from pull-down list; Left,
               Right, Center, to specify the alignment of the banner at top of report(s).

	Logo: Use the Browse button to select a picture to use
               as the logo in reports.  The Clear button will clear the selection.




Tables



	Table cell spacing: Sets the space between table
               cells

	Table cell padding: Sets the space 
               between table cell edges and cell contents

	Table border width: Sets the width of the borders on
               tables.






GnuCash Tutorial and Concepts Guide



This guide is the counterpart to this help. It explains the concepts used in GnuCash and has a tutorial
      that takes you through using GnuCash to manage your accounts. It will appear if you choose
      Open the new user tutorial in the
      Welcome to GnuCash! menu.
To open this Guide manually go to Help → Tutorial and Concepts Guide.
It is strongly recommended to read this guide if you are new to
      GnuCash or unfamiliar with accounting concepts.

Account Register/General Ledger



Account Register & General Ledger Window



This window is used to enter and edit your account data. It also
      provides tools for scheduling future transactions, finding and reporting
      on transactions and printing checks.
To open the Account Register Window for an account, select the
      account in the Account Tree then go to File → Open
      Account or press
      Ctrl+O. This will open
      a new window with the Account Register. Pressing the Open
      button on the Toolbar in the Account Tree Window or the Jump
      button in the Account Register Window are alternate methods.
Figure 4.3. The Account Register Display.
[image: Account Register screen]This is an image of the Account Register tab.






Tip
Appearance of the Account Register Display is highly customizable (see the section called “Changing the Register View”).

Note
The methods to enter transactions are described in detail in Chapter 6, Common Transaction Operations.


Account Register Menus



The Menubar for the Transaction Register window contains the
        following options.
Account Register - File Menu



The following table describes the options in the File.
Clicking on File in the Menubar will “pull down” a
          menu of choices described in Table 4.11, “Account Register - File Menu - Access to file and account operations and
            printing.”.
Table 4.11. Account Register - File Menu - Access to file and account operations and
            printing.
	Menu Item
	Description
	
                  New File (Ctrl+N)
                
	
                  Creates a new data file (starts with new accounts and data.)
                

	
                  Open... (Ctrl+O)
                
	
                  Opens an already existing GnuCash data file.

	Import → 
	
                  Opens the Import sub-menu to import files from other
                  financial programs.

	 	
                  Import QIF ...
	
                  Starts the QIF file Import process.

	 	
                  Import OFX/QFX ...
	
                  Starts the OFX/QFX file Import process.

	 	
                  Import CSV/Fixed-Width ...
	
                  Starts the CSV/Fixed-Width file Import process.

	 	
                  Replay GnuCash .log file...
	
                  Starts the replaying of a GnuCash log file. Used for
                  data recovery from "crashes".

	 	
                  Import MT940
	
                  .

	 	
                  Import MT942
	
                  .

	 	
                  Import DTAUS
	
                  .

	 	
                  Import DTAUS and send
	
                  .

	
                  Save (Ctrl+S)
                
	
                    Saves the currently open file.

                  
	
                  Save As... (Shift+Ctrl+S)
                
	
                    Saves the currently opened file with a different
                    name.

                    Warning
Do NOT store your data file in ~/.gnucash/books. 


                  
	
                  Print Checks... (Ctrl+P)
                
	
                    Starts the Print Checks assistant. See the section called “Printing Checks”.

                  
	
                  Page Setup... (Shift+Ctrl+P)
                
	
                  Let you choose the paper size, layout and margins for printing.

                
	Export → 
	
                  Exports ...

	 	
                  Export Accounts
	
                  Exports your account hierarchy to a new file. Does not
                  export data.

	
                  Properties (Alt+Enter)
                
	
                    Sets options for this GnuCash data file.

                  
	Recently opened files
	
                    Numbered list of most recently opened GnuCash data
                    files.

                  
	
                  Close (Ctrl+W)
                
	
                    Closes the current open account tree, transaction register or report.
                    In the initial Account tree this item is not
                    available - it will be grayed out.

                  
	
                  Quit (Ctrl+Q)
                
	
                    Exits GnuCash.

                  





Account Register - Edit Menu



Table 4.12. Account Register - Edit Menu - Access to file and account
            editing operations and preferences.
	Menu Item
	
                    Description

                  
	
                  Cut (Ctrl+X)
                
	
                    Performs a standard Cut operation.

                  
	
                  Copy (Ctrl+C)
                
	
                    Performs a standard Copy operation.

                  
	
                  Paste (Ctrl+V)
                
	
                    Performs a standard Paste operation.

                  
	Edit Account
	
                    Open form to edit/modify account characteristics and parameters.
                    

                  
	
                  Find... (Ctrl+F)
                
	
                    Set criteria for a search for a specific
                    transaction. See the section called “Find Transactions” for
                    specifics on searches.

                  
	Preferences
                  (Gnucash → Preferences on Mac OS X).
	
                    Customize GnuCash for location, style, and numerous other preferences.
                   See the section called “Setting Preferences”.

                  
	Style Sheets
	
                    Modify/customize Style Sheets.

                  
	Tax Report Options
	
                    Set tax characteristics on account(s) (US). Assign tax form and
                     line to account.  See the section called “Setting Tax Report Options”.

                  





Account Register - View Menu



Table 4.13. Account Register - View Menu - Changes GnuCash display window
             characteristics.
            
	Menu Item
	
                    Description

                  
	Toolbar
	
                    Check-box to enable/disable display of
                    Toolbar.

                  
	Summarybar
	
                    Check-box to enable/disable display of Summary
                    Bar.

                  
	Statusbar
	
                    Check-box to enable/disable display of Status
                    Bar.

                  
	Basic Ledger
	
                Radio button to select register display mode.

	Auto-Split Ledger
	
                Radio button to select register display mode.

	Transaction Journal
	
                Radio button to select register display mode.

	Double Line
	
                Check-box to enable/disable display of Double Line display.

	Sort by ...
	
                Set the sort order of the transactions display. Requires a click to
                 start options form. Option form requires 
                 Cancel/OK to close.

	 	
                Standard Order
	
                Keep normal account order

	 	
                Date
	
                Sort by date

	 	
                Date of Entry
	
                Sort by date of entry.

	 	
                Statement Date
	
                Sort by the statement date (unreconciled items last).

	 	
                Number
	
                Sort by number.

	 	
                Amount
	
                Sort by amount.

	 	
                Memo
	
                Sort by memo.

	 	
                Description
	
                Sort by Description.

	 	
                Action
	
                Sort by action field.

	 	
                Notes
	
                Sort by notes field.

	Filter by ...
	Set filtering for accounts displayed in the Account Tree or
                   transactions in Register display.

	
                  Refresh (Ctrl+R)
                
	Repaint the display screen.

                  
	New Accounts Page
	Open a new tab that display the account tree.
	 





Account Register - Transaction Menu



Table 4.14. Account Register - Transaction Menu - access to transaction tools.
	Menu Item
	Description
	Cut Transaction
	Cut the selected transaction into the clipboard.

	Copy Transaction
	Copy the selected transaction into the clipboard.

	Paste Transaction
	Paste the selected transaction from the clipboard.

	Duplicate Transaction
	Insert in the register a copy of the selected transaction.

	Delete Transaction
	Delete the selected transaction.

	Remove Transaction Splits
	Remove all splits from the selected transaction.

	Enter Transaction
	Enter in the register the transaction you are currently working on.

	Cancel Transaction
	

	Void Transaction
	Void the selected transaction.

	Unvoid Transaction
	Unvoid the selected transaction.

	Add Reversing Transaction
	






Account Register - Actions Menu



Table 4.15. Account Register - Actions Menu - Setup scheduled transactions, repair
            accounts, perform stock splits, transfer and reconcile
            transactions.
	Menu Item
	Description
	Online Actions → 
	This menu item (and sub-menu) is shown only if Online Banking
                was enabled for GnuCash
	 	
                  Get Balance
	
                  

	 	
                  Get Transactions
	
                  Download transactions from online accounts

	 	
                  Issue Transaction...
	
                  Upload transaction(s) to online account ??

	 	
                  Internal Transaction...
	
                  

	 	
                  Direct Debit...
	
                  

	Scheduled Transactions → 
	Scheduled
                Transactions sub-menus
	 	
                  Scheduled Transaction Editor
	
                  Invoke tool to edit scheduled transactions.
                   See the section called “Edit Scheduled Transaction Window”

	 	
                  Since Last Run...
	
                  Display Scheduled transactions since last running of
                  GnuCash.  the section called “Since Last Run Assistant”

	 	
                  Mortgage & Loan Repayment...
	
                  Starts the Mortgage & Loan Repayment assistant for
                  setting up repayments.  the section called “Mortgage & Loan Repayment Assistant”

                
	Budget → 
	Budget
                sub-menus
	 	
                  New Budget
	
                  Opens the window to create a new budget.

	 	
                  Open Budget
	
                  Opens an existing budget.

	
                  Transfer... (Ctrl+T)
                
	
                  Starts the Transfer assistant for transfer between accounts.

	Reconcile...
	
                  Starts the Account Reconcile assistant.   the section called “Reconciling Information Window”

	Stock Split...
	
                  Starts the Stock Split assistant. Additional details the section called “Recording a Stock Split”

	View Lots...
	
                  Opens the Lots in Account form.
                    
                

	Blank Transaction
	
               Move to the blank transaction at the bottom of the register

              
	Split Transaction
	Expand the currently selected transaction
              to show splits.

	Edit Exchange Rate
	
               Edit the exchange rate for the current transaction.

	Schedule...
	
               Create a Scheduled Transaction with the current transaction as a
                template.

	Jump
	
               Jump to the corresponding transaction in the other account.

	Check & Repair → 
	
                    Check & Repair Submenus

                  
	 	
                    All Transactions

                  	
                    Check for and repair unbalanced transactions and
                    orphan splits in this account.

                  
	 	
                    This Transaction

                  	
                    Check for and repair splits in this transaction.

                  
	Reset Warnings...
	
                  GnuCash gives warnings when certain operations are attempted,
                   such as removing a transaction or removing the splits of a transaction.
                   The warning message gives you the option to not give you these warnings
                   when attempting the operation. Check-boxes labeled Remember and don’t ask
                   me again and Remember and don’t ask me again this session allow
                   disabling the warnings. This option resets the warnings to the default,
                   This option resets the warnings to the default,
                   i.e. display all warnings.
                   
Tip
Warnings may be selectivly enabled.


                   

                  
	Rename Page
	
                   Open the form to rename the current page/tab.

                  





Account Register - Business Menu



The items shown in the Business menu are the same listed in Table 4.5, “Account Tree - Business Menu - Access small business features of GnuCash.”.

Account Register - Reports Menu



The items shown in the Reports menu are the same listed in Table 4.6, “Account Tree - Reports Menu -  Access GnuCash Reports and Charts.” plus the
            two types of report listed in the following.
	Account report

	Account Transaction Report




Account Register - Tools Menu



The items shown in the Tools menu are the same listed in Table 4.7, “Account Tree - Tools Menu - Access to miscellaneous tools and editors”.

Account Register - Windows Menu



The items shown in the Windows menu are the same listed in Table 4.8, “Account Tree - Windows Menu”.

Account Register - Help Menu



The items shown in the Help menu are the same listed in Table 4.9, “Account Tree - Help Menu - Access to this help and the Tutorial
          and Concepts Guide.”.


Account Register - Toolbar Icons/Buttons



The GnuCash main Window has a number of
      icons/buttons in the Toolbar
      to quickly access some common functions used with the specific active
      tab. The Toolbar can be hidden or shown by selecting the
      Toolbar item
      on the View menu.
Note
The specific options displayed in the Toolbar varies
      by the functions available to the active tab.

A brief description of the function of a button is displayed when
      the mouse pointer is placed over the button for a couple of
      seconds.
Table 4.16. Account Register (Transaction Register) Window Toolbar 
	Toolbar Buttons
	Description

	
                  Save (Ctrl+S)
                
	Perform a save on the data file, commit all transactions
                to the data file.

	Close
	Close this register.

	Duplicate
	Make a copy of the current transaction.

	Delete
	Delete the current transaction in this register.

	Enter
	Record the current transaction.

	Cancel
	Cancel the current transaction.

	Blank
	Move to a blank transaction at bottom of register.

	Split
	Show all splits in the current transaction.  Not highlighted if
               View → Auto-Split
               Ledger is enableb.

	Jump
	Jump to the corresponding transaction in the other account

              
	Schedule
	Create a Scheduled Transaction with the current transaction as a
               template.

	Transfer
	Start the transfer assistant to transfer funds from one account to
               another.

	Reconcile
	Start the Reconcile process for the selected account.   the section called “Reconciling Information Window”
               

              





Tab Bar



The Tab bar displays “notebook/file folder” style tabs for open
      transaction registers, account trees and reports.

List of Transactions



The List of Transactions displays transactions you have entered
        and a running balance. It also provides a blank transaction to enter
        new transactions. The column headings vary according to what type of
        account you have opened. Common headings are Date,
        Description, Transfer
        and Balance.
The View menu can be used to alter the appearance of the List of
        Transactions. Possible changes are limiting the number of transactions
        shown, using a different sort order and changing the style to more
        easily see transactions. The Split button also provides quick access
        to view all the parts of a transaction.

Summarybar



The Summarybar displays balances appropriate for the opened
        account type at a glance. Usually accounts display Present
        (today’s) account balance, any balance for Future dates,
        a balance for Cleared items,
        a Reconciled balance and a Projected Minimum
        balance. Stock accounts, however, display shares totals
        and their value. The Summarybar can be hidden or shown by selecting
        the View → Summarybar item.

Statusbar



The Statusbar works the same as described in the section called “Statusbar”.


9. TERMINATION




      You may not copy, modify, sublicense, or distribute the Document except as expressly
      provided for under this License. Any other attempt to copy,
      modify, sublicense or distribute the Document is void, and will
      automatically terminate your rights under this License. However,
      parties who have received copies, or rights, from you under this
      License will not have their licenses terminated so long as such
      parties remain in full compliance.
    

Printing Checks



Checks are printed in GnuCash from the account register. GnuCash provides the
     ability to print to several standard Quicken Checks (including US Letter) or to make
     a custom check format. Check position and Date formats are also customizable.
To print a single check in GnuCash, select the transaction to print a check for
     and go to File → Print Checks. 
     This will open the Print Checks properties dialog to print the selected transaction.
To print multiple checks in GnuCash execute a search to find the transactions
     you wish to print.  With the search results window as the front window go to
     File → Print Checks. This will open 
     the Print Checks properties dialog to print all the transactions in the search results window.
The Print Checks dialog has two tabs. The first tab, Options, is used to setup
      the most common options to print a check. The second tab, Custom format, is used to
      setup the position of various fields on the check. It is useful to print a test check
      to a plain piece of paper first and use that to make any adjustments needed.
The default selection in Options is for Quicken/Quickbooks (tm) US-Letter checks.
	Check format: Test with Quicken first then use custom if the position is incorrect.

	Check position: This sets if the Top, Middle or Bottom check is printed.  Custom is used if the
         position of the checks on the page is incorrect.

	Date format: The default here is set in the Preferences International section. Choose a date format.
         This can also be adjusted by the Use of the Months: and Years: lines. Custom allows the date format to be
         set in the Format: box (%m means month, %d means day, %Y means year) A Sample of the format chosen is
         displayed below.

	Address: This sets the address of the Payee, if the check format includes a
          space for it and you are printing a single check.



The Custom format tab has two sections.  The top half of the window (above the
      dividing line) allows you to position the fields in each check.  It contains two
      columns to enter in the X and Y co-ordinates of the field position on the
      check. Positions in the Custom Check Format entry area are specified with x = 0 at
      the left edge of the check with x increasing to the right, and y = 0 at the top edge
      of the check with y increasing as you travel down.  (If you are using a version of
      GTK prior to 2.10, then y = 0 is at the bottom of the page and y increases as you
      travel up.)
	Payee: 

	Date: 

	Amount (words): 

	Amount (numbers): 

	Address: 

	Notes: 

	Memo: 

	Splits Amount: 

	Splits Memo: 

	Splits Account: 



The part of the custom format tab below the dividing line contains fields to
       position the entire check correctly on the page.  The Translation field is the
       distance from the top left corner and the Rotation field rotates the check
       clockwise by the indicated amount.
The Units field in the bottom half of the window specifies the units used in
       all the fields in both halves of the window.
Once OK is pressed on the Print Check dialog the Print GnuCash Document dialog is presented. Press OK
        to print the check.

Pseudo-symbols that can be used for TIAA-CREF quotes



Table A.2. Pseudo-symbols that can be used for TIAA-CREF quotes
	Name
	Pseudo-symbol

	Bond Market
	CREFbond

	Equity Index
	CREFequi

	Global Equities
	CREFglob

	Growth
	CREFgrow

	Inflation-Linked Bond
	CREFinfb

	Money Market
	CREFmony

	Social Choice
	CREFsoci

	Stock
	CREFstok

	Teachers PA Select Stock
	TIAAsele

	Teachers PA Stock Index
	TIAAsndx

	TIAA Real Estate
	TIAAreal






Transfer Funds Window



The method described here uses the Transfer Funds Window to enter a single transaction. This is
           mainly used as a quick way to enter a single transaction without opening the account registers. When
           entering multiple transactions it is recommended to use the register directly.  The Transfer Funds window
           is accessed from Action → Transfer, or by 
           pressing the Transfer icon from the account register tab.
	Enter in the Transfer Information pane the Amount, Date 
              and Description. The Num and Memo fields
               are optional.

	Choose the Transfer From account. If this account is an income or expense account select the
               check-box at the bottom of the Transfer From pane.

	Choose the Transfer To account. If this account is an income or expense account select the
               check-box at the bottom of the Transfer From pane.

	If one of the accounts above is a different currency from the other account the Currency Transfer
               pane will be enabled to add either an Exchange Rate or a To Amount.

	Select OK to commit the transaction or Cancel
               to dismiss the dialog without entering the transaction.
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Exchange Codes for European Markets



Exchange Code List for European Markets
Table A.1. Exchange Codes List for European Markets
	Code
	Market

	BC
	Barcelona

	BE
	Berlin

	BI
	Bilbao

	BR
	Brême

	CO
	Copenhagen

	D
	Dusseldorf

	F
	Frankfurt

	DE
	Xetra (was FX)

	H
	Hamburg

	HA
	Hanover

	L
	London

	MA
	Madrid

	MC
	Madrid (M.C.)

	MI
	Milan

	MU
	Munich

	O
	Oslo

	PA
	Paris

	ST
	Stockholm

	SG
	Stuttgart

	VA
	Valence

	VI
	Vienna







Deleting a Transaction



If a transaction needs to be removed from the register, select the transaction and press either
         the Delete icon on the Toolbar or go to 
         Transaction → Delete Transaction.

         A window will appear to confirm the delete, unless the preference has been changed.  The window presents
         two options; "Remember and don’t ask again", and "Remember and don’t ask again this session". The response
         will be set according to the selected checkbox.  The preference can also be reset via 
         Actions → Reset Warnings.  the section called “Reset Warnings...”.
Parts of a transaction can also be removed by pressing the Split button on
         the Toolbar or selecting 
         Actions → Split Transaction. The part of the
         transaction that needs to be deleted can be then selected for deletion.

Import QIF Files



This Assistant helps you import Quicken QIF files. It will appear if
      you choose Import my QIF files in the
      Welcome to GnuCash! menu.
To start this assistant manually go to File → Import ... → Import
      QIF....
In the following all the screens that you can see in this assistant
      are described in order of appearance.
	The Import QIF files assistant opens with a
      screen that briefly describes what this assistant does and requests the
      file(s) to import. The three buttons at the very bottom of the screen
      will not change while using the assistant.
	Cancel — exit the process and cancel importing
        QIF files.
Warning
If you click this button, any selections you have made up to
          this point will be lost.


	Back — brings up the previous screen so
        that you can change a previous selection until the first screen.

	Forward — brings up the next
        screen so you can continue through the assistant.




	The next screen allows you to Select a QIF file to
      load. The Select... button on this
      screen is used to access the list of files. The
      Select... button brings up the Select
      QIF File dialog.
Navigate to where you have stored your QIF files and select the
      first one then click Import. The next screen will
      display it in the Select a QIF File to Load
      field.
Note
If the file you are loading does not have an QIF date listed
        in it you will see the Set a date format for this QIF file
        screen. Select the proper format from the pull down list and continue.

Note
If the file you are loading does not have an account name listed
        in it you will see the Set the default QIF account
        name screen. Otherwise you will skip this screen and go on
        to the screen in the next section that shows loaded QIF files.
	The Account name: field is used to set
            an account name for this QIF file.





	The next screen shows you the QIF files you have
      loaded. You can use this screen to return to the previous
      screen and load more QIF files. It will also let you unload any files
      you have loaded by mistake.
	The top panel shows the list of QIF Files
          you have loaded.

	The Load another file button takes you
          back to the previous screen to load another QIF file.

	The Unload selected file button allows you to
          select a file from the top panel and remove it from the list.



When you have selected all the QIF files to be imported, click the
      Forward button.

	Depending on the type of data contained in the
      QIF files to be imported, you may see only one or all of the following screens:
	Accounts and stock holdings
	This screen gives a description of the Accounts and stock
      holdings matching process on the following Match QIF
      accounts with GnuCash accounts screen.
Tip
This and other informational screens in the
        Import QIF files assistant
        can be turned off in the Online Banking tab (see the section called “Online Banking”)
        under GnuCash Preferences.

The next screen lets you Match QIF accounts with GnuCash
      accounts. You will see a list of QIF account
      names on the left and suggested GnuCash account
      names on the right. The New? column
      indicates if the GnuCash account name will be created by the QIF
      Import.
To change the GnuCash account to a different one select the QIF
      account. A screen will pop up to select another account or create a new
      one.
	Select an account from the list to choose a already existing
          account.

	The New Account button allows you to
          add a new account name as a sub-account (child of selected) of the
          selected account.

	The OK button is used to confirm your
          selection.

	The Cancel button is used to exit the
          dialog without using any changes you have made.




	Income and Expense categories
	This screen gives a description of the Income and
      Expense categories matching process on the following Match
      QIF categories with GnuCash accounts screen.
Tip
This and other informational screens in the
        Import QIF files assistant
        can be turned off in the Online Banking tab (see the section called “Online Banking”)
        under GnuCash Preferences.

The next screen lets you Match QIF categories with
      GnuCash accounts. You will see a list of QIF
      category names on the left and suggested GnuCash
      account names on the right. The New?
      column indicates if the GnuCash account name will be created by the QIF
      Import.
To change the GnuCash account to a different one select the QIF
      category. A dialog will pop up to select another account or create a new
      one.
	Select an account from the list to choose a already existing
          account.

	The New Account button allows you to
          add a new account name as a sub-account (child of selected) of the
          selected account.

	The OK button is used to confirm your
          selection.

	The Cancel button is used to exit the
          dialog without using any changes you have made.




	Payees and memos
	This screen gives a description of the Payees and
      memos matching process on the following Match payees/memos to
      GnuCash accounts screen.
Tip
This and other informational screens in the
        Import QIF files assistant
        can be turned off in the Online Banking tab (see the section called “Online Banking”)
        under GnuCash Preferences.

The next screen lets you Match payees/memos to GnuCash
      accounts. You will see a list of QIF payee/memo
      names on the left and suggested GnuCash account
      names on the right. The default GnuCash account used is
      called Unspecified. The New? column indicates if
      the GnuCash account name will be created by the QIF Import.
To change the GnuCash account to a different one select the QIF
      payee/memo. A dialog will pop up to select another account or create a
      new one.
	Select an account from the list to choose a already existing
          account.

	The New Account button allows you to
          add a new account name as a sub-account of the selected
          account.

	The OK button is used to confirm your
          selection.

	The Cancel button is used to exit the
          dialog without using any changes you have made.







	The next screen allows you to Enter the QIF file
      currency. The drop down list defaults to the currency
      configured in the Accounts tab (see the section called “Accounts”) under
      GnuCash Preferences. If you wish the new accounts
      to use a different currency, select one from the list.
When you have selected the currency, click the
      Forward button.

	Depending on the type of data contained in the
      QIF files to be imported, you may or may not see one or more of the following screens:
	Tradable Commodities
	This screen gives a description of the Tradable
      Commodities process on the screen.
Tip
This and other informational screens in the
        Import QIF files assistant
        can be turned off in the Online Banking tab (see the section called “Online Banking”)
        under GnuCash Preferences.

A series of screens, one for each of the stock, mutual fund, or
      commodity, displays the exchange, full name, and symbol for each of the commodities
      listed in the QIF file you are importing so that you can
      check them before proceeding.

	Match duplicate transactions
	This screen gives a description of the Match
      duplicate transactions process on the following Select
      possible duplicates screen.
Tip
This and other informational screens in the
        Import QIF files assistant
        can be turned off in the Online Banking tab (see the section called “Online Banking”)
        under GnuCash Preferences.

The next screen lets you Select possible duplicate
      transactions. Imported transactions are shown on the left
      panel and possible matches to each selected transaction are shown on the
      right.
	The left panel shows the list of Imported transactions to
          select from for matching duplicates

	The right panel shows the list of possible duplicates for the
          selected imported transaction. Select the one that most closely
          matches







	The last screen, Update your GnuCash
      accounts, gives you a list of three choices to finish the
      assistant.
	Cancel — exit the process and cancel importing
        QIF files.
Warning
If you click this button, any selections you have made up to
          this point will be lost.


	Back — brings up the previous screen so
        that you can change a previous selection until the first screen.

	Forward — imports the data and creates the
        accounts you have specified.






You should now have successfully imported your accounts.

Business Reports



The Business Reports includes Customer and Vendor Reports and Printable
       Invoices as well as Aging reports.
	Customer Report:

	Easy Invoice:

	Employee Report:

	Fancy Invoice:

	Payable Aging:

	Printable Invoice:

	Receivable Aging:

	Vendor Report:




Chapter 1. Introduction to GnuCash

What is GnuCash?



GnuCash is a personal and small business finance application. It’s designed to be easy to use, yet powerful
     and flexible. GnuCash allows you to track your income and expenses, reconcile bank accounts, monitor stock
     portfolios and manage your small business finances. It is based on professional accounting principles to ensure
     balanced books and accurate reports.

Printing or Exporting Reports and Graphs



Note
 Verify !!!  How customize printing with Gnome?

GnuCash is able to print reports and to export the reports to HTML (web) pages. The
         Print GnuCash Document dialog is accessed from the Print button on the Toolbar or
         go to File → Print in the menu. To Export a report to a web page (HTML) select
         the Export button on the Toolbar and type in a file name.
The Print GnuCash Document dialog is used to select which Printer to send the
         print job to or to print to a File. It also contains a Preview button to view the
         document before printing. Press Print to send the job to the selected printer or
         Cancel to dismiss the Print dialog.
Printing from an open register prints the Account Report, which is also called
         the Register Report. This lists transactions in the account with a total. Other
         reports print as viewed in the Report screen.

Income & Expense



The Income & Expense reports includes the Cash Flow and Income Statement reports.
	Budget Report:

	Cash Flow:

	Equity Statement:

	Expense Barchart:

	Expense Piechart:

	Expense vs Day of Week:

	Income Barchart:

	Income & Expense Chart:

	Income Statement: This report summarizes sources of income and expenditure.
         (This report was called Profit & Loss in gnucash-1.8.)

	Income Statement:

	Income vs Day of Week:

	Trial Balance: This report summarizes sources of income and expenditure.




4. MODIFICATIONS




      You may copy and distribute a Modified Version of the Document under the conditions of
      sections 2 and 3 above, provided that you release
      the Modified Version under precisely this License, with the
      Modified Version filling the role of the Document, thus
      licensing distribution and modification of the Modified Version
      to whoever possesses a copy of it. In addition, you must do
      these things in the Modified Version:
    
	A. 
	    Use in the Title
	    Page (and on the covers, if any) a title distinct
	    from that of the Document, and from those of
	    previous versions (which should, if there were any, be
	    listed in the History section of the Document). You may
	    use the same title as a previous version if the original
	    publisher of that version gives permission.
	  

	B. 
	    List on the Title
	    Page, as authors, one or more persons or entities
	    responsible for authorship of the modifications in the
	    Modified Version,
	    together with at least five of the principal authors of
	    the Document (all of
	    its principal authors, if it has less than five).
	  

	C. 
	    State on the Title
	    Page the name of the publisher of the Modified Version, as the
	    publisher.
	  

	D. 
	    Preserve all the copyright notices of the Document.
	  

	E. 
	    Add an appropriate copyright notice for your modifications
	    adjacent to the other copyright notices.
	  

	F. 
	    Include, immediately after the copyright notices, a
	    license notice giving the public permission to use the
	    Modified Version under
	    the terms of this License, in the form shown in the
	    Addendum below.
	  

	G. 
	    Preserve in that license notice the full lists of  Invariant Sections and
	    required Cover
	    Texts given in the Document’s license notice.
	  

	H. 
	    Include an unaltered copy of this License.
	  

	I. 
	    Preserve the section entitled “History”, and
	    its title, and add to it an item stating at least the
	    title, year, new authors, and publisher of the Modified Version as given on
	    the Title Page.  If
	    there is no section entitled “History” in the
	    Document, create one
	    stating the title, year, authors, and publisher of the
	    Document as given on its Title Page, then add an item
	    describing the Modified Version as stated in the previous
	    sentence.
	  

	J. 
	    Preserve the network location, if any, given in the Document for public access
	    to a Transparent
	    copy of the Document, and likewise the network locations
	    given in the Document for previous versions it was based
	    on. These may be placed in the “History”
	    section.  You may omit a network location for a work that
	    was published at least four years before the Document
	    itself, or if the original publisher of the version it
	    refers to gives permission.
	  

	K. 
	    In any section entitled “Acknowledgements” or
	    “Dedications”, preserve the section’s title,
	    and preserve in the section all the substance and tone of
	    each of the contributor acknowledgements and/or
	    dedications given therein.
	  

	L. 
	    Preserve all the Invariant
	    Sections of the Document, unaltered in their
	    text and in their titles.  Section numbers or the
	    equivalent are not considered part of the section titles.
	  

	M. 
	    Delete any section entitled
	    “Endorsements”. Such a section may not be
	    included in the Modified
	    Version.
	  

	N. 
	    Do not retitle any existing section as
	    “Endorsements” or to conflict in title with
	    any Invariant
	    Section.
	  




      If the Modified Version
      includes new front-matter sections or appendices that qualify as
      Secondary Sections and
      contain no material copied from the Document, you may at your
      option designate some or all of these sections as invariant. To
      do this, add their titles to the list of Invariant Sections in the
      Modified Version’s license notice.  These titles must be
      distinct from any other section titles.
    

      You may add a section entitled “Endorsements”,
      provided it contains nothing but endorsements of your Modified Version by various
      parties--for example, statements of peer review or that the text
      has been approved by an organization as the authoritative
      definition of a standard.
    

      You may add a passage of up to five words as a Front-Cover Text, and a passage
      of up to 25 words as a Back-Cover Text, to the end of
      the list of Cover Texts
      in the Modified Version.
      Only one passage of Front-Cover Text and one of Back-Cover Text
      may be added by (or through arrangements made by) any one
      entity. If the Document
      already includes a cover text for the same cover, previously
      added by you or by arrangement made by the same entity you are
      acting on behalf of, you may not add another; but you may
      replace the old one, on explicit permission from the previous
      publisher that added the old one.
    

      The author(s) and publisher(s) of the Document do not by this License
      give permission to use their names for publicity for or to
      assert or imply endorsement of any Modified Version .
    

Creating a New Account



To create a new account go to Actions → New Account... 
        or click the New Toolbar icon in the Account Tree Window. The New Account
        dialog will be opened.
The New Account properties dialog consists of two tabs, the 
        General tab and the Opening Balance tab.
Creating a New Account involves planning in advance several details that are
         used in the New Account dialog. 
	What type of account is needed.

	Where it fits in the structure of the Chart of Accounts.

	If there is an Opening Balance.

	If there is a Commodity (security/currency) needed for the account.

	If on-line updating of the commodity price is needed.



These details are described below.
General Information Tab



The General tab is used to access the basic information about the
           account. It provides a way of connecting the account to stock information if it is
           one of the currency, mutual fund or stock account types. It can also be flagged as
           a Placeholder account. 
           It displays if it is flagged as a Tax Related account (which
           is set through the Edit → Tax Report
           Options dialog).
There are seven fields in the Identification section of this tab.
	Account Name: The name for the account such as First Bank
               Checking.

	Account Code: The optional number code as described in Accounts codes.

	Description: Optional description for the account.

	Security/Currency: 
Note
The Type field in the Select Security is determined by the selection
                 of Account Type panel in the New Account screen.

	For accounts other than Stock or Mutual Fund this should be the
              default currency, USD (US Dollar) or your local currency symbol. If this account is for a foreign
              currency then use the Select... button to choose a different currency from the
              currencies pull-down list.

	For Accounts containing a Stock and Mutual Fund; 
              first select stock or mutual fund in
              the Account Type panel, then the Parent Account, then use
              the Select... button, to choose the Type (usually the exchange 
              the security is traded on) and security from the Select Security window.
If the required security/fund is not on the list, and you have the correct Type you will need
              to create the security/fund.  To create a commodity for mutual fund and stock accounts select the
              New... button in the Select Security screen, to bring up the
              New Security: screen. The options are described in detail in the Security Editor
              the section called “Security Editor” section.
              Fill in a name, symbol and type and Close
              to create the security.
              After the security is created select the Type: (usually the exchange the security
              is traded on) and the name in the Currency/security: drop down list and
              Close the screen.




	Smallest Fraction: The smallest fraction that will be tracked.

	Account Color: The color to assign to the account’s register tab.
              Click on the color button to open the Pick a Color screen. To reset the account color
              click the Default button.

	Notes: Free form text box. This is used for any additional notes about
               the account.



Below the panes are check-boxes: one to show if the account is Tax
           Related (which is set through the Edit → Tax Report
           Options dialog), and
           two to mark the account as a Placeholder, and/or a
           Hidden account.
The Tax Related check-box means that this account has been
           flagged to be included in the Tax Schedule Report. This flag is only displayed on the Edit
           Account dialog and is set in the Income Tax Information dialog 
           (Edit → Tax Report Options). 
           See the Tax Schedule Report and TXF Export section in Reports Chapter (the section called “General Reports”).
The check-box Placeholder marks this account as solely a placeholder in the
           hierarchy, it is used to enable a hierarchy or chart of accounts to be setup.
Note
A Placeholder means this
             account is not used for transaction data. Transactions may not be posted to this account, only to
             sub-accounts of this account not marked themselves as Placeholder.

The check box Hidden marks this account (and any sub-accounts) to be hidden in
           the account tree and not appear in the pop-up account list in the register.  To reset this option, you will
           first need to open the View → Filter By...
           dialog for the account tree and check the show hidden accounts option.  
           Doing so will allow you to select the account and reopen this dialog.
The next pane contains a list of Account Types. Select a type from the
          descriptions in the section called “Types of GnuCash Accounts”.
The next pane contains an account tree to choose a Parent Account. To create a
           new account tree select New top level account.

           
Note
The available choices in the Account Type pane depends on the selected account in the 
             Parent Account pane. For example if the
             Parent Account is Assets you will see only Equity 
             in the Account Type pane. 
             This is to help maintain a proper account structure for the Chart of Accounts.


           
Steps to enable On-line price updating



	GnuCash relies on an external tool to retrieve online quotes. This
              tool is a Perl module named “Finance::Quote” and has to be installed
              on your computer independently from GnuCash. The first step in enabling online price
              updating should thus be to ensure Finance::Quote is properly installed.
To determine if the Perl module Finance::Quote is already installed on
              your system, type “perldoc Finance::Quote” in a terminal window
              and check to see if there is any documentation available. If you see the
              documentation, then the module is installed, if you do not see the
              documentation, then it has not been installed.
Installing Finance::Quote differs from one operating system to another. For
            the various supported systems, you can follow these guidelines:
	Linux: Most linux distributions (like
              Fedora, openSuse, Mandriva, Ubuntu, and so on) have a package in their software
              repositories for the Finance::Quote perl module. So in most cases, you can
              simply use your preferred package manager (yum, apt, rpm, synaptics, yast,...)
              to install the module. The name of the package may vary from one distribution to
              another. It’s called often something like “perl-Finance-Quote”.

	Windows: Finance::Quote on Windows requires perl
              to be installed already. If you haven’t done so, you should first install ActivePerl.
The Windows installer from the GnuCash home page comes with a small helper program to
              install Finance::Quote for you. You can find it in the Start Menu under the GnuCash
              group and is called “Install Online Price Retrieval”.

	Mac OS X: If you have installed GnuCash
              from the installer found on the GnuCash home page, Finance::Quote is already
              installed for you.

	If none of the above applies to your setup, you can try these
              alternative, more generic instructions:
	Close any GnuCash applications you have running.

	Locate the folder where GnuCash is installed by searching for “gnc-fq-update”
                (without the quotes).

	Change to that directory, open a root shell and run the command “gnc-fq-update”
                (without the quotation marks). This will launch a Perl CPAN update session that will go out onto the
                Internet and install the Finance::Quote module on your system. The gnc-fq-update program is interactive,
                however, with most systems you should be able to answer “no” to the first question:
                “Are you ready for manual configuration? [yes]” and the update will continue automatically
                from that point.






After installation is complete, you should run the “gnc-fq-dump” test program, in the
              same directory, distributed with GnuCash to test if Finance::Quote is installed and working properly.
Note
If you feel uncomfortable about performing any of these steps, please either email the GnuCash-user
               mailing list (<gnucash-user@gnucash.org>) for help or come to the GnuCash IRC channel on
               irc.gnome.org. You can also leave out this step and manually update your stock prices.


	Create the Account for the mutual fund or stock with it listed in the
               Security/Currency field, as described above.
Tip
When creating these accounts it is a good time to create income accounts to track dividends,
                 capital gains (long and short) and expense account(s) for tracking commissions and losses (if you
                 track losses as expenses).


	Create the mutual fund or stock with either the Security Editor for existing stock/funds or the
               New Security/Currency dialog for a new stock/fund.
Select Get On-line Quotes:, Type of Quote Source and
              Timezone.
Online currency quotes require that the check-box for Online quotes and the timezone be
               selected in the Security screen and the Security Editor check-box for "get quote" box is checked for
               those currencies that are to be downloaded.
	Get On-line Quotes: This check-box is to enable this security/fund to
               have quotes downloaded from an on-line source.

	Type of Quote Source use the radio buttons to select the type of source
               for the Online quotes.  Multiple: quote sources like “Europe” should be used if
               fail-over to multiple sites are desirable.  Single: selections will only return
               information from the specified source.
After selecting the type of source for price quotes, select a quote source from the pull-down menu.
               Currently among the supported quote sources are; Yahoo, Yahoo Europe, Fidelity
               Investments, T. Rowe Price, the Vanguard Group, the Australian Stock Exchange
               (ASX) and TIAA-CREF.
Note
Note that Yahoo will provide price quotes for many mutual
               funds including Fidelity, T.Rowe Price and Vanguard, and that the quoted prices
               at Yahoo should be identical to those that may be found at the source sites.

 If you choose Yahoo Europe or Europe, you should append the market code for the security,
               such as PA for Paris, BE for Berlin, etc. Example: 12150.PA (a Peugeot security
               in the Paris market).  Table A.1, “Exchange Codes List for European Markets” below lists codes for various European 
               markets.
Pseudo-symbols for TIAA-CREF funds are listed in table Table A.2, “Pseudo-symbols that can be used for TIAA-CREF quotes”.
              

	Timezone for these quotes: Select the timezone for the source of the
               on-line quotes you are receiving. For example, Yahoo normally quotes Eastern
               timezone, so choose America/New York if you use that quote source.




	Select a commodity to the Price Editor.

	Select Get Quotes in the Price Editor.

	Check the latest price for the selected security.



If you wish to update price quotes from the command line, you can do so by
           the following command;
gnucash --add-price-quotes <gnucash-file-name>
          
The command gnucash --add-price-quotes <gnucash-file-name>
          can be used to fetch the current prices of your stocks.  The file specified
          “<gnucash-file-name>” will depend on the name and location of your
          data file.  This can be determined by the name displayed in the top frame of the GnuCash window,
          before the “-”.  The file name can also be found under File
          in the list of recently opened file; the first item, numbered 1, is the name of the currently
          open file.
This can be automated by creating a crontab entry. For example, to update your file every Friday
          evening (18:00) after markets close (modify the time accordingly for your time zone), you could add
          the following to your personal crontab:
0 18 * * 5 gnucash --add-price-quotes $HOME/gnucash-filename > /dev/null 2>&1
Remember that Mutual Fund “prices” are really “Net Asset Value”
          and require several hours after the exchange closes before being available. If NAVs are downloaded before
          the current days NAVs are determined, yesterday’s NAVs are retrieved.


Opening Balance tab



The Opening Balance tab is visible only when creating a new account. It is
           used to record the beginning balance for an account. This allows it to be used for
           two different scenarios. If using GnuCash for the first time to record transactions,
           it can be used as a beginning balance. If the accounts in use are closed at the end
           of a period and new accounts are created, it is used to close and carry balances
           forward.
There are three panes in this tab. The top pane contains the Balance
           Information.
	Balance: The balance to start the account with.

	Date: The date the opening balance should be recorded.



The next pane is the Transfer Type pane.
	Use Opening Balances Equity account: This transfers the opening balance
               for the account from a standard Equity account called Opening Balances.

	Select Transfer Account: This enables the pane below so a different
               account can be used to transfer the opening balance.



The last pane is the Transfer Account pane. Select the account to use for
           opening balances from the list of accounts in this pane.


Price Editor



The Price Editor is used to track/modify the value of a currency, mutual fund and stocks.
         It provides a unified interface to updating the values of these commodities and is able to update manually
         or through on-line quotes.
Each entry in the editor shows a record of a security/commodity price(s):
	Security: The Security/commodity being priced. The display is sorted
             by the exchange that the individual securities are listed on.  The list is expanded by clicking on the
             caret on the left of the name.

	Currency: The currency the price is recorded in.

	Date: The date the price was recorded.

	Source: The source of the commodities price quote. Typically, this
             will be either user:price-editor, indicating you entered it directly, or Finance::Quote, indicating
             that it was retrieved from an on-line source by the Finance::Quote module.

	Type: There are several different types
            of stock price quotes.
	Bid: Indicates what a specialist dealer is prepared to pay for a
              stock.

	Ask: Indicates at what price the dealers are prepared to sell a
              stock.

	Last: Indicate the price at which the last trade in that
              stock/security occurred at. This is the price most commonly quoted in the media.

	Net Asset Value: Are typically used for mutual funds. They are
              calculated on the net value of the fund’s assets.

	Unknown: Use this if the type of price quoted is not known.




	Price: The actual price of the commodity.



Adding a stock price manually



To add a new price, click on Add, and enter the details of the security and
        price into the dialog box. To edit an existing price, select the price
        in the price list, click the Edit button, and edit the figures.
To remove just one price, select the price and click the Remove
        button. If you want to remove all prices older than a certain date,
        click on the Remove Old button and enter the details in the dialog
        box.
A pop-up will display with the message
         "Delete all stock prices based upon the criteria below:".  Enter the
         date of the last price you wish to delete.
Two check-boxes are below the date field;
	Delete manually entered prices - If checked, delete manually entered stock
           prices dated earlier than the specified date.  Otherwise only stock prices added by Finance::Quote will
           be deleted.

	Delete last price for a stock - If checked, delete all prices before the
           specified date.  Otherwise the last stock price dated before the date will be kept and all earlier
           quotes deleted.




Configuring for use of the Get Quotes button



To support on-line quotations for a particular stock or mutual
        fund account, you must first enable on-line price quoting and select a
        price source in the Security. This is described in detail in the section called “Configuring Securities/Currencies for On-Line Retrieval of Prices”.
        Once on-line quotes are enabled, and Finance::Quote is installed, you can update prices for your stocks and
        mutual funds manually by clicking the Get Quotes button.


5. COMBINING DOCUMENTS




      You may combine the Document
      with other documents released under this License, under the
      terms defined in section 4
      above for modified versions, provided that you include in the
      combination all of the Invariant
      Sections of all of the original documents, unmodified,
      and list them all as Invariant Sections of your combined work in
      its license notice.
    

      The combined work need only contain one copy of this License,
      and multiple identical Invariant
      Sections may be replaced with a single copy. If there are
      multiple Invariant Sections with the same name but different
      contents, make the title of each such section unique by adding
      at the end of it, in parentheses, the name of the original
      author or publisher of that section if known, or else a unique
      number. Make the same adjustment to the section titles in the
      list of Invariant Sections in the license notice of the combined
      work.
    

      In the combination, you must combine any sections entitled
      “History” in the various original documents,
      forming one section entitled “History”; likewise
      combine any sections entitled “Acknowledgements”,
      and any sections entitled “Dedications”.  You must
      delete all sections entitled “Endorsements.”
    

General Ledger



The General Ledger is an advanced register used to enter transactions without needing to open
       individual accounts. The General Ledger shows the transaction entries for all accounts on one register.
Entering transactions in the General Ledger is more complicated than entering them in the individual
       account registers. The advantage is the General Ledger provides a more comprehensive view of the
       transactions you have entered in all your accounts.
The General Ledger defaults to showing only the previous month of transactions. This is changeable
       by using the Date Range on the View menu.

